0

When I run this script on ISQL*Plus everything works fine but then if I try to run this on SQLDeveloper Tiempo1 and Tiempo2 are null, any idea why is this happening?

truncate table a;
call inserta_en_a (1,450000);
call borra_en_a (1,300000);
commit;
select count (*) from a;

variable inicio varchar2 (30)
begin
   :inicio := to_char (systimestamp, 'dd-mm-yyyy hh24:mi:ss.ff3');
end;
/
alter table a shrink space compact;
select systimestamp - to_timestamp (:inicio, 'dd-mm-yyyy hh24:mi:ss.ff3') Tiempo1 from dual;

truncate table a;
call inserta_en_a (1,450000);
call borra_en_a (150001,450000);
commit;
select count (*) from a;

variable inicio varchar2 (30)
begin
   :inicio := to_char (systimestamp, 'dd-mm-yyyy hh24:mi:ss.ff3');
end;
/
alter table a shrink space compact;
select systimestamp - to_timestamp (:inicio, 'dd-mm-yyyy hh24:mi:ss.ff3') 
Tiempo2 from dual;

This is the script I am talking about.

0

Oracle iSQL Plus is merely a web interface to SQL Plus. And have you tried this script straight from the SQL Plus command line? I'd expect it would run, but it doesn't hurt to check.

As for SQLDeveloper: since that is a full development environment, have you checked the permissions on those functions/procedures you are calling (inserta_en_a and borra_en_a) to make sure they are fully accessible from SQLdeveloper? Are all of these on 1 box, or separate servers? I hope the same box. I would check directory permissions to make sure SQLdeveloper can access and write to all the locations you need.

Have you checked your error logs? Are there any entries there? If so, troubleshoot those errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.