1

I have a problem with pureftpd. It stoped suddnly. i run this command netstat -tap | grep ftp but didn't get any output. I run this command nmap my ip and got just http, https and ssh ports listed. It seems pur ftpd not working.

In var/log/pure-ftpd/transfer.log is empty.

I have open all required ports in iptables:

-A INPUT --protocol tcp --match tcp --destination-port 21 --match state --state NEW,RELATED,ESTABLISHED -j ACCEPT
-A INPUT --protocol tcp --match tcp --source-port 1024:65535 --destination-port 1024:65535 --match conntrack --ctstate ESTABLISHED --match comment --comment "Allow passive inbound connections" -j ACCEPT

I tried to stop/start pure-ftpd.

It seems port 21 is closed when i checkd port open. I dont know why pureftpd not BIND any ports.

When i tried to connect through filezilla i got this massage ECONNREFUSED - Connection refused by server

Any idea how to find what is the problem?

  • 1
    Is the pure-ftpd process alive? If it is, did you run netstat as root? – Bass Oct 31 '17 at 8:47
  • How can i check if its alive? yes i run netstat as root. – user3715053 Oct 31 '17 at 9:24
  • something along the lines of ps -ef |grep ftp – Bass Oct 31 '17 at 9:42
  • I got only those: '/usr/lib/openssh/sftp-server /usr/lib/openssh/sftp-server grep ftp' – user3715053 Oct 31 '17 at 9:52
  • It seems not alive? – user3715053 Oct 31 '17 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.