0

I have an issue receiving an email into my server here is what shows in the mail.log file:

Nov  1 10:50:30 hoskin postfix/smtpd[20806]: warning: SASL: Connect to /var/spool/postfix/private/auth failed: No such file or directory
Nov  1 10:50:30 hoskin postfix/smtpd[20806]: fatal: no SASL authentication mechanisms
Nov  1 10:50:31 hoskin postfix/master[1676]: warning: process /usr/lib/postfix/sbin/smtpd pid 20806 exit status 1
Nov  1 10:50:31 hoskin postfix/master[1676]: warning: /usr/lib/postfix/sbin/smtpd: bad command startup -- throttling

Can any help or advise me on what to do?

1
  • Please include your actual configuration in your question. Nov 1 '17 at 11:19
0

First of all welcome to Serverfault. Don't let the downvotes discourage you. Good reading here: https://serverfault.com/help/asking

to fix your issue try this:

chown postfix:postfix /var/spool/postfix/private/auth
chmod 666 /var/spool/postfix/private/auth

Then in /etc/dovecot/conf.d/10-master.conf (or /usr/local/etc/dovecot/conf.d/10-master.conf) modify like this -

      unix_listener auth-userdb {
        mode = 0666
        user = postfix
        group = postfix
      }

  # Postfix smtp-auth
  unix_listener /var/spool/postfix/private/auth {
    mode = 0666
  }  

Then restart dovecot:

/etc/init.d/dovecot restart
1
  • Hi Hayden, I tried what you suggested above and this what I got when I tried to start Dovecot again. Error: service(stats): Socket already exists: /var/run/dovecot/stats Error: service(ssl-params): Socket already exists: /var/run/dovecot/ssl-params there is more error but it exceed the character limit Nov 2 '17 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.