3

I am trying to upgrade from php 5.5 to 5.6, so far i've managed to upgrade to php5.6, setup suPHP 0.7, and add php-mysql extension. I used the webtatic repo to install php 5.6 I read on this page that it is not advised to have webtatic along remi. So i removed the files in /etc/yum.conf.d/ in order to not have webtatic in the list of repo.

However I couldn't install the php-xml for DomDocument, some CMS use it.

I tried :

yum install php-xml

not working

yum --enablerepo remi install php-xml

It gives me the message :

Résolution des dépendances
--> Lancement de la transaction de test
---> Package php-xml.x86_64 0:5.5.38-7.el6.remi will be installé
--> Traitement de la dépendance : php-common(x86-64) = 5.5.38-7.el6.remi     pour le paquet : php-xml-5.5.38-7.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package php-common.x86_64 0:5.5.38-7.el6.remi will be installé
--> Traitement de la dépendance : php-pecl-jsonc(x86-64) pour le paquet : php-common-5.5.38-7.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.5 will be installé
--> Traitement du conflit : php56w-common-5.6.31-2.w6.x86_64 entre en conflit avec php-common < 5.6
--> Résolution des dépendances terminée
Erreur : php56w-common conflicts with php-common-5.5.38-7.el6.remi.x86_64
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest

I tried the --skip-broken parameter but i receive:

--> Lancement de la transaction de test
---> Package php-xml.x86_64 0:5.5.38-7.el6.remi will be installé
--> Traitement de la dépendance : php-common(x86-64) = 5.5.38-7.el6.remi pour le paquet : php-xml-5.5.38-7.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package php-common.x86_64 0:5.5.38-7.el6.remi will be installé
--> Traitement de la dépendance : php-pecl-jsonc(x86-64) pour le paquet : php-common-5.5.38-7.el6.remi.x86_64
--> Lancement de la transaction de test
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.5 will be installé
--> Traitement du conflit : php56w-common-5.6.31-2.w6.x86_64 entre en conflit avec php-common < 5.6

Paquets omis en raison de problèmes de dépendances :
php-common-5.5.38-7.el6.remi.x86_64 depuis remi-php55
php-pecl-jsonc-1.3.10-2.el6.remi.5.5.x86_64 depuis remi-php55
php-xml-5.5.38-7.el6.remi.x86_64 depuis remi-php55

Then I tried rpm -Va --nofiles --nodigest, and then again the previous command, but still can't solve the problem. Thank you for any help !

UPDATE: I manage to get the owner of the remi repository https://rpms.remirepo.net/wizard/, there is a configurator, I chose the version of php, and it laid out the steps to achieve what you want, but unfortunately i had this message :

Erreur du contrôle de transaction :
file /usr/lib64/mysql/libmysqlclient.so.16.0.0 from install of mysql-community-libs-compat-5.6.38-2.el6.x86_64 conflicts with file from package compat-mysql51-5.1.54-1.el6.remi.x86_64
file /usr/lib64/mysql/libmysqlclient_r.so.16.0.0 from install of mysql-community-libs-compat-5.6.38-2.el6.x86_64 conflicts with file from package compat-mysql51-5.1.54-1.el6.remi.x86_64

I am trying to solve this issue now in their forum.

3
  • Migrate to Debian! (But seriously, RPM Hell is why I left Mandrake for Debian...) – RonJohn Nov 2 '17 at 14:38
  • @RonJohn unfortunately it is a legacy install in my company,personally i'd choose Debian as well – Yvon Huynh Nov 2 '17 at 14:52
  • my apologies for the poor attempt at humor. – RonJohn Nov 2 '17 at 15:20
5

Disclaimer: I am having a little trouble with the language barrier, but I think enough of it makes sense along with your description in English.

I think you need to remove the packages that were installed with webtatic, not just remove the repo. Specifically, it looks like php56w-common is from that repo and is the source of your trouble. You'll want to install PHP 5.6 from remi-php56 and stick to one 3rd party ecosystem.

6
  • sorry i forgot to mention the output was in French.. Do i need to revert to php 5.5? OMG it was hard enough to upgrade from 5.5 to 5.6. – Yvon Huynh Nov 2 '17 at 13:37
  • The reason I used Webtatic i because when i wanted to install remi-php56, it says no remi-php56 available. – Yvon Huynh Nov 2 '17 at 13:52
  • 1
    I think this answer is right; try "yum --enablerepo=remi-php56 install php56". If I'm reading correctly, the repository is "remi-php56" not the package. – axus Nov 2 '17 at 14:49
  • 3
    See the Wizard: rpms.remirepo.net/wizard – Remi Collet Nov 2 '17 at 15:04
  • @YvonHuynh That wizard is what you need. (Commented by the author no less!) The package name is just 'php' in the 'remi-php56' repository. It updates the system php package. – Aaron Copley Nov 2 '17 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.