0

My ultimate goal is to install the Python API for Google Earth Engine by running a Datalab Docker container on Google Cloud Platform. As part of the instructions, I needed to install Google Cloud SDK. I have done that and logged into my account after running "gcloud init." However, I cannot create a project on the command line or on web interface. When I try to create a project through the command line, I get the following error message:

Cloud Service disabled by admin. Please contact admin to restore service.

And when I try to create it through the web interface, I just get

Unknown error. 

Now, after digging for a bit, it seems that I need to log into https://admin.google.com/AdminHome and change some settings/permissions. However, I can't even do this, because I fall into an infinite loop with Google's log in page because it doesn't recognize my password (for the record, I know I'm using the right password, since I can log into other pages with it). It just says: 

Something went wrong
Sorry, something went wrong there. Try again.


 Also, I cannot subscribe to the Free Trial because I'm using my institution's email address and I don't have authorization to submit billing information through it.

Any help will be much appreciated.  
 Best, Julio

  • Business accounts are not eligible for free trial. It requires appropriate billing role to set up billing. Also, 'Developer console' service must be enabled on the Gsuite account to create project and use cloud services. It will requires GSuite Super Admin credentials. Did you try to login to GADMIN in incogonito/private browser window. – N Singh Nov 6 '17 at 20:26
  • Thank you for your help! I didn't try logging in with the incognito window. However, as you mentioned, it turns out that my University account did not have the required permissions. I ended up using my Gmail account and it all worked well. – Julio Nov 8 '17 at 7:10
1

As mentioned above by Navi, the problem was with the account type that I was using, since it didn't have the required privileges/permissions. Given that it was an institutional account, it is not a "full" Google account. Everything worked once I redid everything using my regular Gmail account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.