2

I'm struggling to get an lxc container to startup with proper networking.

/etc/network/interfaces:

auto lxcbr0
iface lxcbr0 inet static
        address 192.168.5.69
        netmask 255.255.255.0
        bridge_ports eno1
        bridge_stp off
        bridge_fd 0
        bridge_waitport 0
        bridge_maxwait 0

container config:

lxc.network.type = veth
lxc.network.name = eth0
lxc.network.link = lxcbr0
lxc.network.hwaddr = 26:0b:6c:e8:dc:65
lxc.network.flags = up

When I boot up the container, networking doesn't work. When I look at the bridge config, the container isn't connected:

# brctl show
bridge name     bridge id               STP enabled     interfaces
lxcbr0          8000.509a4c6f57b4       no              eno1

If I manually add the container's virtual network device to the bridge, then everything is groovy:

#brctl addif lxcbr0 veth0BCEEH

These configs are basically from an existing machine with working configurations, so there must be some sort of simple gotcha that I am missing.

How can I get the container to add the veth to the bridge automatically?

In case it matters:

 lxc version: 2.0.7
 Linux hostname 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux
1

I sort of encountered the same; in my case /etc/default/lxc needed updating to contain :

USE_LXC_BRIDGE="false"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.