1

My host OS is OS X El Capitan. My guest OS, OpenBSD 6.1, ran out of disk space, so I ran VBoxManage modifymedium disk OpenBSD\ 6.1.vdi --resize 15000 to resize my VDI from 4GB to 15GB. However my guest OS isn't using the additional space to expand:

[me@puffy:~]$df -lh
Filesystem     Size    Used   Avail Capacity  Mounted on
/dev/wd0a      907M    378M    484M    44%    /
/dev/wd0e      491M    467M   36.0K   100%    /home
/dev/wd0d      2.7G    2.6G   -6.7M   100%    /usr

I tried forcing it to grow by running

[me@puffy:~]$doas -uroot sh -c 'yes > /yesfile'

/: write failed, file system is full

but it ran out of disk space almost immediately.

1

You need to resize the disk partitions and filesystems to make use of the extra space.

You've grown the "physical" disk to 15 GB but the partition table is still only configured as if it was a 4 GB disk, so there's essentially 11 GB of unused space after the end of the last partition.

The command you tried simply filled the root filesystem up, that won't trigger a filesystem (and underlying partition) to grow in any way, you need to do that with partition and filesystem tooling.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.