0

I have a network switch (an HP Procurve) that provides a command line interface that can be accessed via a direct serial port connection. The direct connection is done using an RJ45 connector on the network switch, and a DB9 connector into the serial port on the client computer.

Currently, the switch fault LED is blinking, and the manual indicates that when this happens, one should directly connect to the switch console via a serial connection in order to get more specific debugging information about what is wrong.

So I connect a computer to the network switch using an RJ45-to-DB9 cable. The connecting client computer is running Linux (Debian 8). I then use the minicom tool as a VT-100 terminal emulator. The Network Switch manual indicates that upon connecting to the console, you need to press enter a few times, and then a welcome message should appear. However, when I start up minicom and press enter 5 to 10 times, nothing happens - i.e. no text appears at all.

What I've tried so far:

  1. First step to debug this was to check what serial ports are available or enabled on the client computer. When I type dmesg | grep tty I see that /dev/ttyS0 seems to be available and enabled:

    serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    

    Just to make sure, I tried writing a byte to the serial port, by doing:

    echo -en ' ' > /dev/ttyS0
    

    This returned without any error. If I try the same using a different device, like /dev/ttyS2, I get an Input/Output error, so this increases my confidence that /dev/ttyS0 is an enabled, valid serial port device.

  2. Secondly, I look in the HP Procurve manual to make sure all the connection settings are correct. The manual indicates that the serial connection should be done using any baud rate from 2400 to 115200, 8 data bits, 1 stop bit, no parity, and flow control set to None. I configure minicom following these settings exactly (with a 9600 baud rate). Minicom specifies settings for both hardware and software flow control (this distinction is not made in the procurve manual) so I set both to None anyway. Finally, I make sure minicom is using /dev/ttyS0 and I save the minicom configuration settings.

    So far, the connection still doesn't work. When I start up minicom and press enter 5 to 10 times, no text appears.

  3. To rule out a potentially bad RJ45-DB9 cable, I try two other RJ45-DB9 cables. Still no text appears when I start minicom and press enter 5 to 10 times.

  4. I try a few other "wild guess" debugging techniques, like rebooting the switch and also rebooting the client computer. Still doesn't work.

Question: Given everything I've tried, is the most likely problem here something with the Network Switch itself? Could it simply be the switch itself is damaged in some way that has disabled the CLI? Or is there something obvious I'm missing here in terms of configuring a minicom client to connect to a serial port?

  • Could be the switch is borked. Have you tried other baud rates? That would jsut as likely cause this. The switch will be set to ONE rate, and cannot auto-negotiate in almost all cases. – Spooler Nov 13 '17 at 18:30
  • The switch manual claims the switch will auto detect the client rate, and that any rate between 2400 and 115200 would work – Siler Nov 13 '17 at 20:07
  • Have you tried: - Sending a break signal (CTRL-A then F in Minicom, if I recall correctly) - Power on the switch while having minicom running? If there is nothing on the screen, it is a bad indication. Even with improper speed settings, some garbage should appear. – Pablo Nov 13 '17 at 21:07
  • Procurve switches have life-long warranty. Just call HPE and they'll replace it. – Zac67 Nov 14 '17 at 22:17
  • I assume you're not able to connect to the switch in-band via SSH or Telnet? If you can there's nothing a serial console will really add to your ability to troubleshoot the fault LED (unless you reload and want to watch the boot process). Otherwise, I have seen this before on these switches where the serial port on the switch locks up and is only solved by a power-cycle. Are you seeing this even after a power-cycle or do you not have that luxury (e.g. live services)? – Mintra Nov 16 '17 at 19:14

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.