-2

I was running on elasticsearch 2.3.1, but I had to upgrade to 5.6.4 (because I wanted to install Kibana/Sense), but ElasticSearch won't start anymore.

This is log from ElasticSearch:

java.lang.IllegalStateException: The index [[cyclone3.mysite_sk/Qf5ccdWNRYKFGs4lBffSAQ]] was created with version [1.2.1] but the minimum compatible version is [2.0.0-beta1]. It should be re-indexed in Elasticsearch 2.x before upgrading to 5.6.4.

And lot of the same errors.

Yes I understand that I need to reindex, but how? And does I lose all data?

THIS IS NOT A DUPLICATE OF ElasticSearch doesn't start after installing 5.6.4 BECAUSE THIS IS ON THE DIFFERENT SERVER

1

You need to re-index to be able to do that. Follow the following guide for help on how to do it

https://www.elastic.co/guide/en/elasticsearch/reference/master/reindex-upgrade.html

  • But it is Reindex before upgrading, I already upgraded it (I think, because I cannot run "curl -XGET 'localhost:9200'", because I cannot start ElasticSearch). I upgraded it by executing 5.6.4 deb file. – tomsk Nov 13 '17 at 22:36
  • @tomsk You can still probably reindex, but you need to delete the bad indexes first. The data you have won't work with 5.x. – jordanm Nov 14 '17 at 1:00
  • Don't worry, elasticsearch sucks for everyone, just ask Nick Craver – Jacob Evans Nov 14 '17 at 5:38
  • But if I delete indexes I will lost data, no? And how can I reindex if elasticsearch wont start. – tomsk Nov 14 '17 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.