0

I'm trying to setup multiple VLAN on my TP Link TL-SG2424 L2 managed switch but I'm not sure if I quite get the concept, or if I'm simply being stupid?!

So I have ~ 17 machines connected to my switch, which is in turn connected to the internet (and DHCP server) using a Draytek Vigor router via switch port 1 into router port 1.

On my Draytek I have 3 LAN's configured -

LAN1 - 192.168.1.10 - 192.168.1.255 (default)

LAN2 - 192.168.2.10 - 192.168.2.255

LAN3 - 192.168.3.10 - 192.168.3.255

DrayTek LAN configuration

I then have the following VLAN configuration -

VLAN 0 - Port 1, Subnet LAN 1, no VLAN tag

VLAN 1 - Port 1, Subnet LAN 2, VLAN Tag 20

VLAN 3 - Port 1, Subnet LAN 3, VLAN Tag 40

DrayTek VLAN Configuration

So my understanding is that I can now configure my switches to tag certain devices to belong in that port group. As such, they'll be assigned to the VLAN's respectively.

So on my switch I've created my VLAN with ID 20 and marked ports 8-12 as being part of VLAN 20 and removed them from Default VLAN (1).

Default VLAN

TP Link VLAN Configuration

I'd then expect traffic from devices I've plugged into 8-12 to be assigned with VLAN tag 20 and as such be assigned with an IP within the 192.168.2.1 range from the DrayTek router (or am I misunderstanding switch VLAN)?

Anyway, that isn't what is happening and I can't figure out why. I've tried various configurations and having no luck... I really, really hope someone can help!

1

Sorry, silly mistake but this might help others -

I wasn't tagging port 1 (the link to router/DHCP) in my VLAN group so essentially port 1 wasn't a member (which it needs to be). In addition, ports 8-12 don't need to be tagged as they already have the unique VLAN assigned to that entire port -

Correct VLAN port assignment

Note how port 1 (my outbound connection) is tagged and the rest are marked as members but left untagged.

  • 1
    Exactly. You need tagging to pass multiple VLANs between switches & other network devices using a single port, but other ports should only have one VLAN untagged. – Esa Jokinen Nov 14 '17 at 16:15
  • Yes so the idea understanding I got from this is that internally the switch knows where to route etc, but if travelling out of that group, it requires the network traffic to be tagged so the router/other devices can make sense of the data? And if I was to create a LAG, would each member of that LAG need to be tagged within the VLAN to offer the redundancy? Thanks for helping me understand :) – Chris Nov 14 '17 at 16:28
  • 1
    I'm not sure how this is done with TP-LINK, but it seems LAG refers to Port Trunking. If ports are configured as a trunk, they must have the same settings and a trunk with the same configuration on the other switch. On some switches trunking simply makes a new virtual port you can configure, and disables altering these settings per individual trunked ports. – Esa Jokinen Nov 14 '17 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.