0

I am using kolla/kolla-ansible 5.0.0 and I just built all the container images and pushed them to my local docker registry. There is one image that kolla fails to build which is the fluentd image. Below is my error I get in the fluentd.log:

INFO:kolla.image.build.fluentd:Step 7/8 : RUN ulimit -n 65536     && gem install --minimal-deps activesupport:4.2.9
 public_suffix:2.0.5 fluent-plugin-parser fluent-plugin-kubernetes_metadata_filter fluent-plugin-elasticsearch flue
nt-plugin-grep fluent-plugin-grok-parser:0.3.1 fluent-plugin-rewrite-tag-filter     && chmod -R 440 /etc/sudoers.d/
kolla_fluentd_sudoers      && chmod 755 /usr/local/bin/kolla_extend_start     && mkdir -p /var/run/fluentd     && c
hown -R fluentd: /etc/fluentd /var/run/fluentd
INFO:kolla.image.build.fluentd: ---> Running in 58b04375bfb9
INFO:kolla.image.build.fluentd:unable to convert "\x84" from ASCII-8BIT to UTF-8 for lib/active_support/values/
unicode_tables.dat, skipping
INFO:kolla.image.build.fluentd:
INFO:kolla.image.build.fluentd:Successfully installed concurrent-ruby-1.0.5
INFO:kolla.image.build.fluentd:Successfully installed i18n-0.9.1
INFO:kolla.image.build.fluentd:Successfully installed minitest-5.10.3
INFO:kolla.image.build.fluentd:Successfully installed activesupport-4.2.9
INFO:kolla.image.build.fluentd:Parsing documentation for concurrent-ruby-1.0.5
INFO:kolla.image.build.fluentd:Installing ri documentation for concurrent-ruby-1.0.5
INFO:kolla.image.build.fluentd:Parsing documentation for i18n-0.9.1
INFO:kolla.image.build.fluentd:Installing ri documentation for i18n-0.9.1
INFO:kolla.image.build.fluentd:Parsing documentation for minitest-5.10.3
INFO:kolla.image.build.fluentd:Installing ri documentation for minitest-5.10.3
INFO:kolla.image.build.fluentd:Parsing documentation for activesupport-4.2.9
INFO:kolla.image.build.fluentd:Installing ri documentation for activesupport-4.2.9
INFO:kolla.image.build.fluentd:Successfully installed public_suffix-2.0.5
INFO:kolla.image.build.fluentd:Parsing documentation for public_suffix-2.0.5
INFO:kolla.image.build.fluentd:Installing ri documentation for public_suffix-2.0.5
INFO:kolla.image.build.fluentd:Successfully installed fluent-plugin-parser-0.6.1
INFO:kolla.image.build.fluentd:Parsing documentation for fluent-plugin-parser-0.6.1
INFO:kolla.image.build.fluentd:Installing ri documentation for fluent-plugin-parser-0.6.1
INFO:kolla.image.build.fluentd:Successfully installed lru_redux-1.1.0
INFO:kolla.image.build.fluentd:Building native extensions.  This could take a while...
INFO:kolla.image.build.fluentd:ERROR:  Error installing fluent-plugin-elasticsearch:
INFO:kolla.image.build.fluentd: serverengine requires Ruby version >= 2.1.0.
INFO:kolla.image.build.fluentd:
INFO:kolla.image.build.fluentd:ERROR:  Error installing fluent-plugin-rewrite-tag-filter:
INFO:kolla.image.build.fluentd: serverengine requires Ruby version >= 2.1.0.
INFO:kolla.image.build.fluentd:

You can see at the bottom that it is complaining about not being able to install fluent-plugin-elasticsearch and fluent-plugin-rewrite-tag-filter. It says serverengine requires Ruby version >= 2.1.0. How can I get it to have ruby 2.1 and will that fix it?? I really need this container to build.

0
  1. Vi /usr/share/kolla/docker/fluentd/DockerFile.j2
  2. Find where it says RUN ulimit -n 65536 ** and replace the second line that starts with **&& gem install with the following text:

    && gem install --minimal-deps activesupport:4.2.9 public_suffix:2.0.5 fluent-plugin-parser fluent-plugin-kubernetes_metadata_filter fluent-plugin-elasticsearch:1.10.2 fluent-plugin-grep fluent-plugin-grok-parser:0.3.1 fluent-plugin-rewrite-tag-filter:1.6.0 fluent-plugin-secure-forward \

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.