0

I have a 6.5 VM running off a local datastore, no network involved except for the web UI, no vCenter, dead simple.

With a single Virtual disk, all is fine. If I want a second virtual disk (another .vmdk on the same datastore) then I can add this while the VM is running, and it works. I have added it, formatted it and stored things on it from within the VM.

But it won't boot. If I reboot the server, it cannot find the boot HDD. I can remove it, boot the server and then add it while the server is running, but that is hardly a solution.

Hard Disk details below. Any idea why this isn't booting?

Hard disk 1 
Backing [LOCAL4TB] MANTICORE/MANTICORE.vmdk
Capacity    200 GB
Thin provisioned    No
Controller  SCSI controller 0:1
Mode    Dependent

Hard disk 2 
Backing [LOCAL4TB] MAILSRV/500G.vmdk
Capacity    500 GB
Thin provisioned    No
Controller  SCSI controller 0:0
Mode    Dependent

Boot Options
Firmware
Choose which firmware should be used to boot the virtual machine:
BIOS (Recommended) (I have tried EFI to no effect)
Boot Delay
Whenever the virtual machine is powered on or reset, delay boot by
0 milliseconds
Force BIOS setup
The next time the virtual machine boots, force entry into the BIOS setup screen.
Failed Boot Recovery (NOT TICKED)
When the virtual machine fails to find a boot device, automatically retry boot after 10 seconds (NOT TICKED)

Thanks everybody.

2

Note the order of your disks. Your "second" disk is actually the scsi disk 0:0 and your "first" disk is 0:1.

Change the order in the VM settings and your VM will boot from the correct disk.

enter image description here

This is configurable when the VM is powered off.

  • Any idea how that happened? – ewwhite Nov 15 '17 at 12:10
  • eww - I can clarify, I will do so in my answer below. But the short version is it's my mistake. – fishkake Nov 15 '17 at 16:37
0

Gerald solved my problem (I'm slightly ashamed for not figuring this out), but I thought it prudent to add a bit of detail, and answer the very valid question in the comment - why I ended up here.

Originally this Hypervisor machine (OCELOT) had almost no local storage, and this VM (MANTICORE) had a single hard disk running on an ISCSI datastore on another server (LEMUR). I then installed local storage in OCELOT and decided to move MANTICORE's disk to it, as I wanted to decommission LEMUR.

To do this without vCenter, I shut down MANTICORE and copied the vmdk file (using datastore browser), from the datastore on LEMUR to the datastore on OCELOT. Then I added this as a disk, which assumedly added it on SCSI 0:1. Then I removed the original disk, and all was well. Since there was only one disk, it didn't matter. Then I added the new disk, and ended up where I am now. So that's how it happened.

The only other detail for anyone else who stumbles upon this is that you can't do the switch in one config change. You have to change the second disk to an unused controller (like 0:6) then SAVE! Then edit again, move the first disk to 0:0 and the second one to 0:1. If you try to do it in one, it appears to save but actually reverts. Just adding this because it caught me out ever so slightly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.