0

I've got an exchange server that has stopped receving external email this morning.

I noticed almost straight away that if i telnet from the machine itself to 127.0.0.1 on port 25 I get a proper SMTP response, however If I do that externally on the servers public IP, I get disconnected immediately.

We use mimecast's antispam service and mail is being queued there with 'Null response from socket' as the status, so I'm pretty sure the server isn't listening properly on port 25.

Did some googling and some troubleshooting but am still no closer to having this fixed.

Heres what I've tried so far...

  • restarted the transport service

  • restarted the server

  • disabled the default receive connector and created a new one

  • disabled the anti-malware within exchange

  • removed and re-added DNS settings

  • restarted the server again

Any help gratefull received.

UPDATE: ##################### After some further testing and diagnostics, I can also see that mail which is being sent outbound is not sending; Users are seeing mail is sitting in their 'outbox' and not leaving the server.

#
  • Which AntiSpam Service are you using? – BastianW Nov 17 '17 at 9:17
  • we use mimecast – John Nov 17 '17 at 9:29
  • Get-ReceiveConnector | fl output please – Jacob Evans Nov 17 '17 at 14:39
  • Please confirm it's actually listening on the appropriate IP:PORT. Execute netstat -ano | find ":25" in CMD Also, do you have enough disk space? – Vick Vega Nov 20 '17 at 23:14
0

I noticed almost straight away that if i telnet from the machine itself to 127.0.0.1 on port 25 I get a proper SMTP response, however If I do that externally on the servers public IP, I get disconnected immediately.

That's a pretty good indication that the problem is not at the server itself, which means that...

Heres what I've tried so far...

restarted the transport service
restarted the server
disabled the default receive connector and created a new one
disabled the anti-malware within exchange
removed and re-added DNS settings
restarted the server again

Was fairly pointless.

What kind of router/firewall is in front of the server and have you checked that? That's likely where the problem exists.

Try to telnet to the server like in your initial test but from another machine on the same network. If you again get the appropriate response then you can almost definitely point to your router/firewall as the cause of the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.