I'm trying to install a MikroTik Cloud Core Router CCR1009-7G-1C-1S+PC. Our internet comes from an antenna and the main cable (from the antenna) first connects to a PoE injector (Phihong POE61U-560DG). The cable which comes out of the PoE injector is our internet connection and works fine, if I connect it to a basic Wifi router it works like a charm. However, I want the Cloud Core Router to handle this part, but when I connect the PoE cable to the router there is no link. No LED is blinking.

So, right now, I have to connect the powered ethernet cable to the Wifi router and from the Wifi router to the Cloud Core Router, this works. But why does it work on the Wifi router and not on the CCR? Is there a setting that I need to change in RouterOS? I have absolutely no idea what this is causing. The cable is the same, standard Cat. 6 ethernet cable. And the Wifi router is nothing special at all.

The port doesn't matter either, none of the 7 ports are working with said cable.

Thanks for any suggestions

  • I'm confused about the PoE aspect. It sounds like the PoE injector is powering the antenna. If that's the case you are not plugging a "powered cable to the router", as the power only goes to the antenna. Are you saying that if you power the Mikrotik up via mains, then connect to the input of the injector you don't get a link on any port, but do on the old router? – USD Matt Nov 17 '17 at 13:52
  • Yes, the PoE injector powers the antenna. Sorry, I was confused about this. The thing is that the main cable goes from the MikroTik router into the PoE injector and from there to the antenna. But whatever port I try, there is no link. Would it work if I connect the cable to the PoE port in the MikroTik router, so I could get rid of the PoE injector? – Andreas Remdt Nov 17 '17 at 14:07
  • It doesn't seem to support powering devices from the PoE port, only powering the router itself and I'd rather just use the mains adaptor on a router like this. Are you able to get a link / access the router if you plug other devices into it? If you get a link to the antenna on the old router but not the Mikrotik, I'd probably try setting the relevant port to 100Mbps first to see if it's a negotiation problem. – USD Matt Nov 17 '17 at 14:14
  • Yes, if I plug other devices in it works just fine. Only with the antenna cable there is no link at all. I will try to set the port speed to 100Mbps and see what happens – Andreas Remdt Nov 17 '17 at 14:21
  • Thanks, setting the port speed to 100Mbps fixed it, seems like this was the problem. – Andreas Remdt Nov 18 '17 at 17:19

As USD Matt wrote the problem was with the negotiation, after I set 100Mbps as a fixed speed it worked fine. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.