0

I'm updating from Exchange 2013 RTM to Exchange 2013 CU18.

Exchange upgrade is failing currently with the following error...

Microsoft Exchange Server 2013 Cumulative Update 18 Unattended Setup

Copying Files... File copy complete. Setup will now collect additional information needed for installation. Languages Mailbox role: Transport service Client Access role: Front End Transport service Mailbox role: Client Access service Mailbox role: Unified Messaging service Mailbox role: Mailbox service Management tools Client Access role: Client Access Front End service

Performing Microsoft Exchange Server Prerequisite Check

Configuring Prerequisites                                 COMPLETED
Prerequisite Analysis                                     COMPLETED

Configuring Microsoft Exchange Server

Organization Preparation                                  FAILED
 The following error was generated when "$error.Clear();
    install-GlobalAddressLists -DomainController $RoleDomainController

" was run: "Microsoft.Exchange.Data.Directory.ADObjectAlreadyExistsException: Ac tive Directory operation failed on HOSTEX-1.mydomain.cloud. The object 'CN= Default Global Address List,CN=All Global Address Lists,CN=Address Lists Contain er,CN=Hosted Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration ,DC=mydomain,DC=cloud' already exists. ---> System.DirectoryServices.Protocols. DirectoryOperationException: The object exists. at System.DirectoryServices.Protocols.LdapConnection.ConstructResponse(Int32 messageId, LdapOperation operation, ResultAll resultType, TimeSpan requestTimeOu t, Boolean exceptionOnTimeOut) at System.DirectoryServices.Protocols.LdapConnection.SendRequest(DirectoryReq uest request, TimeSpan requestTimeout) at Microsoft.Exchange.Data.Directory.PooledLdapConnection.SendRequest(Directo ryRequest request, LdapOperation ldapOperation, Nullable1 clientSideSearchTimeo ut, IActivityScope activityScope, String callerInfo) at Microsoft.Exchange.Data.Directory.ADDataSession.ExecuteModificationRequest (ADObject entry, DirectoryRequest request, ADObjectId originalId, Boolean emptyO bjectSessionOnException, Boolean isSync) --- End of inner exception stack trace --- at Microsoft.Exchange.Data.Directory.ADDataSession.AnalyzeDirectoryError(Pool edLdapConnection connection, DirectoryRequest request, DirectoryException de, In t32 totalRetries, Int32 retriesOnServer)
at Microsoft.Exchange.Data.Directory.ADDataSession.ExecuteModificationRequest (ADObject entry, DirectoryRequest request, ADObjectId originalId, Boolean emptyO bjectSessionOnException, Boolean isSync) at Microsoft.Exchange.Data.Directory.ADDataSession.Save(ADObject instanceToSa ve, IEnumerable
1 properties, Boolean bypassValidation)
at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADConfigurationSessi on.Save(ADConfigurationObject instanceToSave) at Microsoft.Exchange.Management.Deployment.InstallGlobalAddressLists.CreateD efaultGal(ADObjectId defaultGal) at Microsoft.Exchange.Management.Deployment.InstallGlobalAddressLists.Interna lProcessRecord() at Microsoft.Exchange.Configuration.Tasks.Task.b__b()
at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String fun cName, Action func, Boolean terminatePipelineIfFailed)".

The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the :\ExchangeSetupLogs folder.

Any help at all is appriciated!

  • 1
    Are you running the setup from Administor's CMD prompt? – Vick Vega Nov 20 '17 at 22:50
  • Doh.... possibly not! seems to be progressing now! facepalm – John Nov 20 '17 at 22:58
  • Please add your response as an answer :) – John Nov 20 '17 at 22:58
0

Please stop the installation process, we need to upgrade Exchange 2013 CU15 and install .NET Framework 4.6.2, then upgrade to CU18.

More information, refer to: Exchange 2013 CU16 and Exchange 2016 CU5 .NET Framework Requirement

  • Windows updated have been kept up to date on the server in question and it doesn't fail prerequisites, as that article would suggest. On that basis, do i still need CU15 first? – John Nov 22 '17 at 13:12
  • Does the installation process run prepare AD and schema now, or the CU18 installation is completed? If so and no error returns, check the .Net Framework version first, ensure it's 4.6.2. – Jianfei Wang Nov 23 '17 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.