2

I'm installing the CU18 upgrade for Exchange 2013.

Its failing on the UM role bit, because its looking in the wrong place for a file! :(

Mailbox role: Unified Messaging service                   FAILED
 The following error was generated when "$error.Clear();
      install-MsiPackage -PackagePath $RolePackagePath -LogFile $RoleLogFile Path -UpdatesDir $RoleUpdatesDir -PropertyValues

("INSTALLDIR="" + $RoleInstall Path + "" ESE=1"); " was run: "Couldn't open package 'D:\en\UMLanguagePack.en-US.msi'. This installation package could not be opened. Verify that the package exists and th at you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.".

The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the :\ExchangeSetupLogs folder.

There is no D drive on my machine, I have C and E. Its a VM, so the installation media is downloaded and isn't an iso, so definately not a D drive.

The file in question resides in E:\Software Install\exchange\en

Is there a way I can fix this and make it look in the right place?

Thanks in advance

  • I've created a VHD and copied the install files to it, mounted it as D and am trying again... fingers crossed – John Nov 21 '17 at 0:22
2

It's a solution that manually create a folder, and copy related file into this folder.

Besides, we could remove watermark from Registry: HKLM\SOFTWARE\Microsoft\Exchange server\V15\Unified Messaging.

Note: please backup this key first before remove it.

Then, install Exchange by PowerShell:

  1. Locate to Exchange installation path. For example: CD: E:\Software Install\exchange
  2. Run: Setup.exe /mode:upgrade /IAcceptExchangeServerLicenseTerms

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.