1

My Bind Server configuration works .. Just not very well and I am not sure what the underlying cause is, or where to fix it.

I have a DNS dedicated server. ns1.ywpadmin.com. It's public IP address is 40.142.31.33 and internal ip address is 10.0.0.200

My web server is located at 40.142.31.34.

The website I am testing is roofrightroofing.net

Now when I go to whatsmydns.net Only about half of the servers worldwide show up with the green check mark.

When I run dig roofrightroofing.net SOA @localhost from the DNS server -- I get (keep in mind I haven't set up the NS2 server yet. I want my config functional before that happens):

;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40310
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;roofrightroofing.net.      IN  SOA

;; ANSWER SECTION:
roofrightroofing.net.   38400   IN  SOA ns1.ywpadmin.com. admin.ywpadmin.com. 1494612100 10800 3600 604800 38400

;; AUTHORITY SECTION:
roofrightroofing.net.   38400   IN  NS  ns1.ywpadmin.com.
roofrightroofing.net.   38400   IN  NS  ns2.ywpadmin.com.

;; ADDITIONAL SECTION:
ns1.ywpadmin.com.   38400   IN  A   10.0.0.200
ns2.ywpadmin.com.   38400   IN  A   10.0.0.200

;; Query time: 3 msec
;; SERVER: ::1#53(::1)
;; WHEN: Tue Nov 21 14:30:03 CST 2017
;; MSG SIZE  rcvd: 181

Here is the configuration for my bind server:

named.conf.options

options {

    dnssec-validation auto;
    auth-nxdomain no;    # conform to RFC1035
    listen-on-v6 { any; };
    recursion no;
    version "Not Disclosed";

};

named.conf.local

//roofrightroofing.net--
zone "roofrightroofing.net" {
         type master;
         file "/var/lib/bind/roofrightroofing.net.hosts";
         };
//--roofrightroofing.net

roofrightroofing.net.hosts

$ttl 38400
roofrightroofing.net.                       IN          SOA      ns1.ywpadmin.com. admin.ywpadmin.com. (
                            1494612100
                            10800
                            3600
                            604800
                            38400 )
roofrightroofing.net.                       IN       NS      ns1.ywpadmin.com.
roofrightroofing.net.                       IN       NS      ns2.ywpadmin.com.
roofrightroofing.net.                       IN       A       40.142.31.34
www.roofrightroofing.net.                   IN       A       40.142.31.34

ywpadmin.com.hosts

$ttl 38400
ywpadmin.com.                       IN          SOA      ns1.ywpadmin.com. admin.ywpadmin.com. (
                            150000000 ;serial number
                            10800 ; Refresh
                            3600 ; Retry
                            604800 ; Expire
                            38400 ) ; Negative Cache TTL


ywpadmin.com.           IN      NS      ns1.ywpadmin.com.
ywpadmin.com.           IN      NS      ns2.ywpadmin.com.
ns1.ywpadmin.com.       IN      A       10.0.0.200
ns2.ywpadmin.com.       IN      A       10.0.0.200
ywpadmin.com.           IN       A       40.142.31.34
www.ywpadmin.com.       IN       A       40.142.31.34

Godaddy Configuration

A     @    40.142.31.34
NS    @    ns03.domaincontrol.com   
NS    @    ns04.domaincontrol.com


------------ HOSTS -------------
Host    IP Addresses    
NS3    40.142.31.33 
NS4    40.142.31.33 
NS1    40.142.31.33 
NS2    40.142.31.33

Again I will be setting NS2 - NS4 up AFTER my configuration is solid.

I have tried updating the serial for this specific website multiple times and still I am having issues. What else can I do as far as my server configuration or troubleshooting? Is this a GoDaddy config issue or a BIND zone issue? Does anything glaring look incorrect?

2 Answers 2

0

The whois for ywpadmin.com shows that ns03.domaincontrol.com and ns04.domaincontrol.com are authoriative for this zone.

You should probably update the godaddy configuration so that 40.142.31.33 becomes authorative for ywpadmin.com. You typically use a glue record for ns1.ywpadmin.com -> 40.142.31.33, unless you already have another domain pointing to this host.

0

I know this is a long time gone, but a recent upvote on the question prompted me to answer with what helped me solve this issue. I thought that it was enough to update the serial and to restart bind. WRONG! You need to flush rndc as well! So when updating a zone file. One should

  1. Update the serial number
  2. Flush RNDC name of host file you edited
  3. Reload RNDC
  4. Restart BIND

The flush and restart commands I user are:

sudo rndc flushname example.com.hosts 
sudo rndc reload
sudo service bind9 restart

This lets all the other DNS servers know that you've cleared the cache for that domain, it has a new serial and the content of the file has changed. I've noticed that MOST DNS servers will pick up almost immediately -- But some can take up to 48 hours.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .