0

I am working on setting up a PXE based build system in our environment.

Short description on how it will work is, server will boot into network, get an IP address and PXE server details from DHCP server and then we select the rebuild option in the PXE menu. Then, it should download the kickstart file over http. Here is the problem, I noticed that in my couple of test servers this step is failing as it cannot download the Kickstart file.

Few additional points:

There is no problem with the HTTP server as there is another server which is getting rebuilt successfully (in the same setup). And even the problematic servers used to work fine before and it stopped working all of a sudden. I am able to download the kickstart file using wget.

I tried looking around but couldn't find anything amiss. Out of my three test servers, two of them are Dell PowerEdge R710 and the third one is a desktop. All three used to work fine but since last few days, one Dell PowerEdge server and the desktop started having this issue. Attached a screenshot on how its trying to download the kickstart file. For troubleshooting, I tried changing 'inst.ks' to 'inst.repo' in the PXE menu file and it still fails.

Let me know if something isn't clear. Any pointers will be helpful. Thanks.

enter image description here

  • "No carrier detected on interface em4" -- You can't download a file from a web server without a network. Is this the correct interface? – Aaron Copley Nov 29 '17 at 20:25
  • That's just a snippet of the output.. Its actually suppose to use em1 (which is the right interface). I believe it's something to do with http (probably some cache issue that I am missing...). – Ram Kumar Dec 5 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.