1

On my free trial Azure account, I'm working on Exercise 5 of this official Azure lab tutorial to work on the section Connect as a database contained user to an Azure SQL database. I've successfully created the ADSQLUser as described in the previous sections of the Exercise 5. But when I try connecting to the SSMS in VM (Windows Server 2016 with SQL Server 2016) using the info shown in the image below, I get the following error:

Error:

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. (Microsoft SQL Server, Error: 18456)

SSMS login dialog:

enter image description here

Note: The same above dialog connects to the SQL Server fine if I use ADSQLAdmin..... instead of ADSQLUser..... in the User Name dropdown above. But according to the tutorial it should connect for ADSQLUser..... as well. So what I may be missing?

2

When you connect SQL, click Option, in the Connect to database text box, type <your database name>. They must be same, otherwise you will get this error.

enter image description here

  • That was it. Instead of typing the db name I was looking into the db dropdown and the dropdown did not have that db. After your suggestion of typing the db name, I typed it and it works now (Thank you). – nam Nov 24 '17 at 16:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.