2

Trying "apt-get install net-snmp" command to use SNMP commands. but the server says "Unable to locate package net-snmp"

This is where I'm told I require Net-SNMP; http://php.net/manual/en/snmp.requirements.php

but it looks like net-snmp isn't available from the repositories of this installation

This is for a Turnkey Linux web server.

Please help?

  • Which SNMP command do you need? As a command line programs or from a language such as PHP? – Patrick Mevzek Nov 26 '17 at 23:43
1

I reckon you want to install the php5-snmp package.

FWIW, TurnKey Linux is based on Debian. TurnKey v14.x = Debian Jessie.

FYI I discovered that by doing a package search (scroll about halfway down to "Search package directories") for "php snmp" in "oldstable" (i.e. Jessie). If you'd done a search from the commandline, you probably would have found something similar. E.g.

apt-cache search snmp php

Like most other commandline tools, you can also leverage grep if you get too many results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.