0

I'm trying to use mod_disk_cache to speed up a web site that is running on WordPress. Whenever I enable it with

CacheEnable disk /

and the rest being the stock Ubuntu configuration I start to get the wrong results. When I see the main page it's fine, but when I go to a specific post I get a RSS feed instead. Like if the cache is returning the wrong content.

I've disabled my RewriteRules as it seems mod_cache doesn't work with that.

I'm not even sure where to start to debug such a thing. Any ideas?

1

Making a small change to the Rewrite rules in your .htaccess file should solve this. There is, apparently, a known bug in apache. I had the exact same problem, albeit a different flavor of unix (FreeBSD), and the fix given at this link below absolutely solved it: http://core.trac.wordpress.org/ticket/12175

0

Bug?: Bug #219914 in apache2 (Ubuntu): mod_disk_cache enabled globally by default

0

I couldn't found why this was happening but I solved it by using WP Super Cache; which greatly increased the performance of my Wordpress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.