9

I'm trying to run Hyper-V on a freshly installed Windows 10 Pro (1709) on AMD FX 6350, 8 GB RAM. Hyper-V Virtual Machine Management (vmms) starts properly but Hyper-V Host Compute Service (vmcompute) crashes with the error Windows could not start the Hyper-V Host Compute Service on Local Computer. Error 0x80070005: Access is denied.

In the log only meaningless message The Hyper-V Host Compute Service service terminated with the following error: General access denied error.

Googling finds a similar error when migrating or exporting virtual machines, but not the first time Hyper-V starts with no VMs are created.

Previously, this hardware was Windows 7 and Vmware Player worked fine. Now I want to try "native" virtualization.

By the way, exactly the same problem on the laptop on Intel i5-2430M.

4
  • Encountered exactly the same problem after installing the latest November Cumulative updates. Previously, Hyper-V and vmcompute launched fine on Fall Creators Update (1709). Naturally, disabling and enabling Hyper-V again doesn't help, nor is this a permissions problem with the Hyper-V user folder. Process Monitor also doesn't suggest any filesystem or registry permissions issue for vmcompute so far. Like you said, this is different from the issues posted on the internet.
    – StepS
    Dec 8, 2017 at 11:36
  • The latest Cumulative update was released November 30th, and I haven't yet confirmed if that's the one causing the issue (will be reverting later today and editing the post with new information). If you have it installed, might try to revert as well. The two Cumulative Updates installed for me are KB4051963 and KB4048955, with KB4051963 being the Nov 30 one.
    – StepS
    Dec 8, 2017 at 11:36
  • KB4048955 there wasn't in my system. But KB4051963 there was and it uninstalling doesn't resolve the problem. Dec 9, 2017 at 0:04
  • Welcome to Server Fault. This is not a forum; it is not necessary to use things like "SOLVED" or "EDIT" to mark a question. You may mark a question as solved by ticking the mark next to the answer which solved your problem (as you have already done). Jan 4, 2018 at 17:26

1 Answer 1

10

This is known to be caused by disabling Windows Control flow guard (CFG).

To turn this back on:

  • Search for and open Windows Defender Security Center on the start menu.

  • Go into App & browser control: Windows Defender Security Center

  • Scroll to the bottom and click on Exploit protection settings: App & browser control

  • Ensure that Control flow guard (CFG) is set to On by default: Exploit protection settings

This morning my Hyper-V was working, then this evening it wasn't. Disabling CFG was the only noteworthy activity I had done on Windows aside from regular application use. After re-enabling the feature, Hyper-V was working again for me.

I disabled the feature in the first place due to an issue with Windows 10 build 1709 which is severely impacting my TortoiseGit performance in that the diff tool takes about 5 seconds to open.

Another users comment on that page reports the same problem.

1
  • Thanks! This fixed issues I had starting docker because hyper-v wouldn't start.
    – Matt
    Oct 11, 2018 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.