I have a Windows Server 2012 R2 Terminal server on a standalone workgroup.

The client asked for the C drive to be hidden so I enabled the "User configuration\Administrative Templates\Windows Components\File Explorer\Hide these specified drives in My Computer" group policy and set it to hide all drives.

After some time the client wished to reshow the drive and I disabled the group policy and rebooted the PC but the drive did not return.

I checked the registry and under HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer the NoDrives dword was still there so I set it to 0, rebooted and the problem still persisted.

The NoDrives dword was also present under group policy objects associated with individual profiles in HKEY_USERS.

Things I have tried:

  • I set all instances of NoDrives to 0 and rebooted the system

  • I deleted all instances of NoDrives and rebooted the system

  • I logged off a user account, renamed their user profile in C:\Users and deleted their key from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

  • I reenabled the group policy and set it to only hide A and B drives

All have failed. Is there something I am missing?

1 Answer 1


I solved this by doing the following:

  • Deleting registry.pol from %Systemroot%\System32\GroupPolicy\User
  • Opening gpedit.msc and enabling User Configuration\Windows Components\File Explorer\Hide These Specified Drives in My Computer
  • I set the setting to Do Not Restrict Drives.

Simply setting the group policy was not enough, deleting the registry.pol file was required. This will only require you to recreate policies under User Configuration, machine policy is in it's own file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .