2

I am trying to verify a SSL connection to one of my (sub) domains. I've installed a wildcard cert on IIS for a particular sub domain. When I check the connected website instance via https://www.geocerts.com/ssl_checker it all checks out just fine.

I used the same wildcard cert for my FileZilla Server instance on the same server. I've tried to connect (using the same sub domain) to it with different clients (FileZilla, Cyberduck, Transmit, Forklift) and they all connect fine and without a CERT warning with the exception of FileZilla. But when my colleagues (and customers) connect they get a CERT warning saying that they need to trust the CERT. As I understand FileZilla always ask for 'trust' and that there is no way around it, but the other clients are warning as well.

So I tried to verify via open sll via the command

openssl s_client -showcerts -connect my.subdomain.io:990

But I am getting the error/message

Verify return code: 21 (unable to verify the first certificate)

Could this have anything to do with th CERT warnings or is there something I am doing wrong or forgot to configure?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.