2

I have recently installed netdata on my Debian 8 server (monitoring software) and afetr installing my Debian 8 server is reporting the below two alerts constantly.

  • 1m ipv4 tcp listen overflows = 37 overflows
  • 1m ipv4 tcp listen drops = 3 drops

I was wondering if anyone could suggest any settings to reduce/stop these errors, maybe some sysctl.conf settings will correct this?

Currenty I have attempted to reduce with the below sysctl.conf settings (with no luck).

net.netfilter.nf_conntrack_max = 524288

net.ipv4.tcp_syncookies = 1

net.ipv4.tcp_max_syn_backlog = 65535

net.ipv4.tcp_max_orphans = 65535

net.ipv4.tcp_synack_retries = 3

net.ipv4.tcp_max_tw_buckets = 1440000

net.ipv4.tcp_tw_recycle = 1

net.ipv4.tcp_tw_reuse = 1

net.core.somaxconn = 65535

net.core.netdev_max_backlog = 65536

net.ipv4.tcp_abort_on_overflow=0

  • you need to check the listen backlog in you application man listen and resize net.core.somaxconn – c4f4t0r Dec 10 '17 at 22:48
  • I have already set the net.core.somaxconn = 65535 to the highest setting? – daygle Dec 10 '17 at 22:50
  • 1
    what application are you using? because the application needs to set the backlog option when calling listen syscall – c4f4t0r Dec 10 '17 at 23:15
  • Hmmm I assumed it was Debian and not the application, anyway I'm using github.com/UNOMP/unified-node-open-mining-portal. – daygle Dec 10 '17 at 23:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.