0

I have a folder to make accessible for specific users on a windows server(Datacenter 2016).

I have created a file share and created a user with a password on the server and granted the user access to the share and the full set of permissions. I removed Everyone from the permitted users.

The client is connected by logging in with those credentials from the user on the server. However, it then says that the folder cant be accessed(at all) due to lacking perissions. When I allow Everyone to access the share, the client can log in, but still can't write to the directory even though the user the client is logged in as has been granted full permissions.

I looks like the client is not actually connected as the user it is logged in as? How can I log in to a shared folder as a user(on the server) and also have the user's permissions?

1

When accessing a remote share, there are 2 levels of permissions. The effective permissions are the most restrictive combination of the Share permissions and the NTFS permissions. Which type of permissions have you set? Check the other type to see what is in place there as well. With the GUI use the Sharing tab for share perms, and the Security tab for NTFS permissions.

It sounds like the user does not have NTFS permissions to the data. In many cases its easier to use share perms of Everyone/Full or Everyone/Change and then get specific with the NTFS perms so you only have one set of perms to manage. Local users access is only subject to NTFS permissions.

1
  • I did as you said (user had the permissions, and removed the inherited NTFS "read" for everyone... After that it worked... I'm sure about the exact cause, but it works now! Thanks! – rudib Dec 14 '17 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.