0

I am having issues with Hyper-V WS2016 VM, especially when using docker.

We have recently installed several Windows server 2016 Virtual Machines on a host with Intel Xeon E5-2620 v4 CPU. We allocated 2 to 3 vCPUs per machine. The host is from a third party and we have no direct access to Hyper-V manager. The problem is that they run slow at times, even freeze from time to time, even though CPU usage is less than %10. It hardly goes higher than this.

We would like to use docker containers for Windows on one of the VMs. However, docker is taking way too much time to extract the image before catastrophically ending with a file read error. Download process does not take much, but the problem is extracting. The image that we are using in our build is the official windowsservercore image. We have tried that with different tags. An output from a small test project pulled from repo is here:

https://imgur.com/a/JTHgw

This one uses the iss:windowsservercore image, other tags had the same issues as well. Curiously, the official hello-world project with nanoserver can be run. But it too takes too much time to extract and run.

Also, I tried updating Windows on 2 of the VMs. One of them is the one where we will use docker, and the other is not. The former is telling me that there were some problems with the Update in the update status screen whereas latter is stuck in the restart phase, I can only see "restarting" in the screen while signing in via remote desktop.

I am assuming these may be problems with WS16 and the way Hyper-V runs WS16 images, or Hyper-V settings. We are also using VMs with WS2012, and they run with no issues. Another culprit I suspect is the hard drive, as extraction of images fail with a read error though installing programs was relatively fast and disks are SSDs and there's plenty of empty space on all of the machines.

Can this be a problem with processor assignment? Should we tell the server provider to adjust VM settings, if you can think of any? I thought Nested virtualisation is not enabled and it is causing a problem, but I was able to pull and run the "hello-world" image, also another image with windows nanoserver in it.

Thank you in advance :)

  • 1
    You're using docker on windows? brave man – Chopper3 Dec 13 '17 at 17:39
  • Yeah... I am starting to feel like that as well... Not my decision tbh ¯_(ツ)_/¯ Already ran into other issues with swarm, etc. – Yamaç Kurtuluş Dec 13 '17 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.