4

I'm on Windows Server 2016 Datacenter with Storage Space volumes. I deleted a large 3TB file on my 12TB thinly provisioned volume. This space hasn't been reclaimed. So I decided I would need to run Optimize-Volume.

So I ran Optimize-Volume -DriveLetter D 2 days later it's still running, showing what it did from the first second which is:

"1/2 completed - 00:00:00 remaining

Optimizing volume

Running

[ ]

Screenshot of this

According to the Optimize-Volume documentation, running Optimize-Volume on a Thinly provisioned drive with no arguments should run as though these arguments were provided:

-Analyze -SlabConsolidate -Retrim.

CPU has been staying at around 15% for "Service Host: Disk Defragmenter"

So my questions are:

1) Is this going to stop? I know this is on a big drive so I didn't expect it to be quick, but the progress bar hasn't moved since it started (it started at 50%) - so I'm not sure if it's making any progress.

2) Did I run the best command? Would it have been better to provide the -retrim and -slabconsolidate arguments (and not provide the -analyze argument?) - Should I also have provided the -verbose argument, as it's not providing me much info at the moment!

3) Should I let it run, or should I ctrl-c it? If I ctrl-c it will it gracefully stop what it's doing? I don't want it to corrupt any data.

Thanks

4

No, it shouldn't work this way. You can try to spawn Process Monitor to see is there any System activity while all other tasks aren't running. If there's no activity at all you can kill optimization process and restart it... What it might be: You launched optimize with a low priority (default) and it just doesn't start in the background. Try to relaunch with -NormalPriority switch applied.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.