0

I would like to upgrade Varnish 3 to 4 but without losing old cache(varnish 3 cache)

Could someone please help with this?

I replaced the VCL file and tried to reload getting VCL syntax error.

Message from VCC-compiler: Expected one of 'acl', 'sub', 'backend', 'director', 'probe', or 'import' Found: 'vcl' at ('input' Line 2 Pos 1) vcl 4.0;

-----

Running VCC-compiler failed, exit 1 VCL compilation failed Command failed with error code 106 varnishadm -S /etc/varnish/secret -T 127.0.0.1:6082 vcl.load failed

Thanks in Advance.

0

You'll need to rewrite your VCL config, as Simon said. My answer here includes a fixed wiki link, and a tool that will help with 3-4 migration.

Varnish 3 to 4 upgrade config changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.