0

I am new to Robocopy and have been scouring over articles and technical forums. I seem to have the basic copy working fine from the testing I have been doing, however, my log file is virtually complete junk. The test script I am running currently is:

c:\robocopy.exe "C:\RobocopyTest" "J:\Root" /mir /v /tee /Log+:"c:\FreeNasBackup.txt"

The log is created ok, but when I open it, it seems mostly like a bunch of jumbled up information, and nothing like the examples I see on the internet.

The following is the output from the above command:

C:\RobocopyTest\J:\Root*.* . /V /TEE /S /E /DCOPY:DA /COPY:DAT /PURGE /MIR /R:1000000 /W:30 C:\RobocopyTest\Microsoft-Windows-Dhcpv6-Client%4Admin.evtxMicrosoft-Windows-Kernel-Boot%4Operational.evtxMicrosoft-Windows-Kernel-EventTracing%4Admin.evtxMicrosoft-Windows-Kernel-Power%4Thermal-Operational.evtxMicrosoft-Windows-Kernel-ShimEngine%4Operational.evtxC:\RobocopyTest\Layer1\Key Management Service.evtxMicrosoft-Windows-Application-Experience%4Program-Compatibility-Assistant.evtxMicrosoft-Windows-AppXDeploymentServer%4Restricted.evtxC:\RobocopyTest\Layer1\Layer2\Microsoft-Windows-Kernel-ShimEngine%4Operational.evtxMicrosoft-Windows-Kernel-StoreMgr%4Operational.evtxMicrosoft-Windows-Kernel-WHEA%4Errors.evtxMicrosoft-Windows-NCSI%4Operational.evtxNew Text Document.txt 3 2 1 0 0 0 13 13 0 0 0 0 816.0 k 816.0 k 0 0 0 0

This is being run on Windows Server 2016. For now, I would like to start with as much information in the log as possible, and then cut back as I figure out information that is not needed. I just need it to be presented in a layout that is quicker, and easier to read. Any suggestions on where I went wrong?

  • While I'm not testing with Win2016, robocopy is not normally kept on the root of C: (c:\robocopy.exe ...) and it's not reporting a normal header Robocopy has always produced for me, can you confirm that is the exact line used? tried it without the "c:\" part before robocopy.exe? – Halfdone Dec 18 '17 at 2:35
  • I had moved a copy of Robocopy.exe to the root in an attempt to simplify things until I had them working at a basic level. When I ran robocopy in its native location as a .bat, it would not execute, which is why i tried a different location. It appears in doing so I caused an unforeseen issue. – Frosty81 Dec 18 '17 at 4:32
  • I edited the script to point at robocopy's native location in the system32 folder and everything came out as expected. So somewhere along the way as I worked to resolve this issue, i fixed the .bat running from the system32 issue. Thanks for the direction. Now to see if there is anyway to get mt and transfer speeds together. How do I give your answer credit? – Frosty81 Dec 18 '17 at 4:37
  • I can submit it as an answer. Did you happen to call your bat script "robocopy.bat" (or have one somewhere on the system) that can cause an issue like this where the script calls itself instead of robocopy.exe and cause loops or otherwise confuse stuff. – Halfdone Dec 18 '17 at 15:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.