9

My shared drives were inaccessible after updating my windows 10 to the latest “Windows 10 Fall Creators Update”.

Within the latest “Windows 10 Fall Creators Update” the Guest access in SMB2 is disabled by default.

You can change this setting within your group policy settings.

Right click the Windows Icon at the bottom left of the task bar, or select the windows key + r

Within the run box, type “gpedit.msc”

Within the local Group Policy Editor, select “Administrative Templates”

Select “Network”

Select ”Lanman Workstation”

Double click “Enable Insecure guest logons” option

Tick the “Enable” option

Select OK

If this did not work consider checking this registry key too:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth

It should be set to 1 for your case.

Note: By enabling insecure guest logons, this setting reduces the security of Windows clients. https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

4 Answers 4

18

Within the latest “Windows 10 Fall Creators Update” the Guest access in SMB2 is disabled by default.

You can change this setting within your group policy settings.

Right click the Windows Icon at the bottom left of the task bar, or select the windows key + r

Within the run box, type “gpedit.msc”

Within the local Group Policy Editor, select “Administrative Templates”

Select “Network”

Select ”Lanman Workstation”

Double click “Enable Insecure guest logons” option

Tick the “Enable” option

Select OK

If this did not work consider checking this registry key too:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth

It should be set to 1 for your case. (Credits: zhqiat)

Note: By enabling insecure guest logons, this setting reduces the security of Windows clients. https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

2
  • Finally found your answer, thank you :)
    – Ngoc Nam
    Dec 26, 2019 at 9:37
  • That last bit (registry check) did it for me - thanks!
    – Mark
    Feb 18, 2021 at 18:27
4

One additional thing to look into.

If you apply the gpedit.msc solution as qore5 has mentioned and it still does not work, you may need to edit a separate registry key.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

and change AllowInsecureGuestAuth to 1.

This has happened after several Windows 10 updates.

1
  • Hope this gets more upvotes. For the time being I will include it in the accepted answer to be seen. Dec 4, 2020 at 16:43
1

The accepted answer works by lowering the security on the client side. It is not enforcing the restriction in Windows 10 / Windows Server which was added for security purposes. It requires adjusting each of your clients.

On the other hand, the real answer is to raise the security on the server side and remove any mapping to guest accounts

ADD THESE LINES [global] client min protocol = SMB3 client max protocol = SMB3 restrict anonymous = 2 encrypt passwords = true REMOVE

  • the map to guest option (which I had as bad user)
  • any 'guest ok' line in your smbd.conf

restart samba and you'll be prompted for a username/password instead.

-1

Simple>>

Unhide Files and Folder

Go to C:\Windows\System32\GroupPolicy

1st make a backup Machine & User folder and also gpt.ini

__then

Delete items in Machine folder & User folder (*Do not delete Machine & User folder)

__go back

Delete gpedit.msc from C:\Windows\System32

Restart your computer

and then enjoy your life..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.