0

After installing PHP soap when I run php via command line it throws an error:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_soap.dll' - /usr/lib/php/20151012/php_soap.dll: cannot open shared object file: No such file or directory in Unknown on line 0

It won't throw error if I comment out: extension=php_soap.dll in: /etc/php/7.0/cli/php.ini

Installed via apt-get php7.0-soap and restart both nginx and php.

Running ubuntu with latest packages.

PHP 7.0.26-2+ubuntu16.04.1+deb.sury.org+2 (cli) (built: Dec 7 2017 20:09:40) ( NTS ) Copyright (c) 1997-2017 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies with Zend OPcache v7.0.26-2+ubuntu16.04.1+deb.sury.org+2, Copyright (c) 1999-2017, by Zend Technologies

Also in /etc/php/7.0/cli/conf.d/20-soap.ini there's a symlink pointing to: /etc/php/7.0/mods-available/soap.ini

  • Did you ever solve this? I'm having a similar issue – twigg Aug 6 '18 at 13:34
  • 1
    Yes I needed to edit the phpini duplicate for the command prompt. Run php --ini to find the location – John Magnolia Aug 29 '18 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.