I have an Ubuntu 16.04 server with two WD Reds. When I first installed them, the disks were already vibrating. I did not expect this since they are not mounted.

Does anyone know what the reason behind this is? It would be nice if the disks are idle when not used.

P.S. I used a PCIE expansion card (delock 89270) to connect these drives to my server. I do not know if this matter, but I wanted to mention it.

1 Answer 1


WD Reds are optimized for NAS use, and thus expected to run pretty much continuously.

A hard disk cannot start spinning instantly: if a disk was stopped when an I/O request for it arrived, it would incur several thousands of milliseconds of extra latency as the disk would have to spin up before the request could be satisfied.

It is possible to configure the disk to go to power saving mode if it's been idle for a specified amount of time, but this is not the default for WD Reds. (Some WD Green models do that by default - but that is not always a good thing: see the description of the -J option in the man page of the hdparm command.)

You could use the blktool or hdparm commands to intentionally send the disks that are unmounted and you're not going to use into a power saving state, causing them to spin down.

Disks don't know whether they are mounted or not: the disk controller will just send in requests to read or write groups of blocks. After all, you can read or write unmounted disks e.g. using the dd command.

Mounting a filesystem in Linux basically means that certain kinds of metadata and caching are maintained in RAM for efficient filesystem access.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.