1

I have two servers connected via point-to-point Fibre Channel (QLogic cards). The file server is running FreeBSD and has the iSCSI Target The other is running Debian and is the Initiator. The target from the fileserver shows up as /dev/sdb on the Debian server.

Everything works fine except that if I reboot the fileserver, the Debian server loses the connection.

I can force it to rescan by issuing the command echo 1 > /sys/class/fc_host/host1/issue_lip But then it shows up as /dev/sdc

Is there a better way to restore the mount?

  • Why are you using an FC HBA to do iSCSI???? – Chopper3 Dec 24 '17 at 22:54
  • Maybe iSCSI is the wrong term. But from everything I find on google, the target config is like setting up iSCSI but you give the target a port of "isp" to bind it to the FC HBA. – dwilliss Dec 26 '17 at 16:14
  • You're massively out of your depth here if you don't know the basics of what you're trying to do - perhaps get someone in to help you as you're going to struggle fumbling your way forward – Chopper3 Dec 27 '17 at 12:19
  • That's why I'm here - to learn. – dwilliss Dec 27 '17 at 19:41
  • Maybe read what this site is and isn't for if you would please. – Chopper3 Dec 28 '17 at 15:19
1

The solution turns out to be to mount the drive by UUID, not /dev/sdX1.

You can look in /dev/disk/by-uuid to find the UUID that is a symbolic link back to the partition you want. Then in the host file, mount it using:

UUID=whatever-the-uuid-is-here  /mountpoint  ext4  defaults 0 0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.