4

Nearly 10 years ago I built a PC for a friend and thought it would be a good idea to use the motherboard's RAID controller to set up a RAID 1 array. Since HDDs have a propensity to die quicker than a motherboard and most people upgrade their computers every handful of years, it seemed like a reasonable implementation at the time. Unfortunately, although it was initially set up as a gaming computer for him (something that would almost mandate being upgraded to keep up with current games), my friend stopped gaming and mainly just checks email, and occasionally surfs the web a little. So, it's gone all this time without ever being upgraded. Needless to say, I'm now in a situation where the motherboard died before the drives and I need to recover data for him.

The motherboard is/was an MSI K9A2 Platinum (MS-7376) which uses the Promise Technology PDC42819 chip (the same as their FastTrak TX2650 and TX4650 cards). I've tried a handful of utilities to no avail. DiskInternals, iCare, EaseUS... After hours of running their scans, they all show files in a jumbled mess of folders and files... and none of them were able to actually recover anything.

My options at this point seem to be:

  1. Paying several hundred dollars to a professional data recovery firm. Most have guarantees at least, but with their advertised costs being so high I don't want to use them unless I absolutely have to.
  2. Buying a used replacement motherboard for over $200. This should work, but the motherboard is so old that it costs more now than it did when it was new and will be worthless once the data is recovered.
  3. Gambling on a used $100 RAID card with the same chip. This might work, but I've never done a RAID migration from a motherboard controller to a dedicated RAID card... so I have little faith that it will actually work.
  4. Some other software recovery tool or trick that I've yet to try. Nothing's worked so far, but there's a lot out there. Most of what I've found doesn't even address RAID 1 oddly enough. I've also seen mention in another post about using DD to make a copy of the drive and skipping the initial header blocks to strip out the RAID 1 information... but, I'm not familiar with how to find out how much would data need to be skipped... or if that method would even work with this particular RAID implementation.

I'm open to try different tools/techniques to recover the data from the drive(s). Any insight or experience in handing this kind of recovery would be greatly appreciated.

Also, for reference, I'm actually not 100% sure that the motherboard is dead. The system powers on but doesn't even make it to POST... just board lights and fans... No beep codes... No video of any kind. My hunch is something with the motherboard, but it could be a baked CPU too. Although... The CPU fan still works and the heat sink was not plugged with dust, so I don't think it was actually cooked. The PC just flat out died... no weird glitching before death like is common with overheating. I've also tried different RAM and video cards too to no avail just to cover my bases. But, I don't have a spare CPU to test and obviously I don't have a spare motherboard.

4

Your single "sibling" drive should be working. Spawn any recent and decent backup app and just... do a backup! Then you can build new RAID1 using whatever tech you want (better something built-in into your OS of choice) and remember: RAID isn't a backup! Always follow 3-2-1 rule, except primary data at at least one external NAS box + combine with cloud (AWS Glacier or B2 are both dirt-cheap these days).

https://knowledgebase.starwindsoftware.com/explanation/the-3-2-1-backup-rule/

https://www.backblaze.com/blog/the-3-2-1-backup-strategy/

https://www.veeam.com/blog/how-to-follow-the-3-2-1-backup-rule-with-veeam-backup-replication.html

0

RAID 1 is basically just mirroring, so in theory you could take any of the two drives and extract all data from it.

Pretty obviously, the Promise controller used a custom layout of the disk. What it most probably did is to put some controller metadata on the start of the disk and push user data (MBR + partitions) up by a certain amount or offset.

If you figure out the offset and copy everything from there to the end, you should have a working image. Depending on how the disk was partioned, the first sector of the disk should contain the boot sector with the strings Invalid partition table.Error loading operating system.Missing operating system towards the end (BIOS style, most probably) or the second sector should start with EFI PART (UEFI style, unlikely).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.