1

I‘ve tried to copy files from my Mac to a Debian server with rsync. Therefore I installed the current version via Homebrew.

Now the sync is working but my files are owned on the destination by root (the ssh-user) although I use the —chown=www-data:www-data or —usermap=*:www-data Options. It seems that rsync is ignoring them.

Any ideas?

2

The obvious problem that I can see is that the options you've provided are not correct.

Instead of --chown your question has -chown, containing a single Unicode emdash instead of the expected two standard hyphens.

The same is true of --usermap where your question instead shows —usermap.

0

It was a version issue so the version on my mac os doesn't support the --chown etc options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.