2

I have tried solutions presented in the following posts:

https://unix.stackexchange.com/questions/364529/centos-vsftpd-not-starting/364555

https://superuser.com/questions/987912/why-my-vsftp-service-cant-start

VSFTP Fails to start CentOS 7

I am trying to set up a new FTP user from the server terminal. I just got the site up with a basic index.html, which is great! But need much more than that.

Running systemctl restart vsftpd returns this message:

Job for vsftpd.service failed because the control process exited with error code. See "systemctl status vsftpd.service" and "journalctl -xe" for details.


Here is the result of systemctl status -l vsftpd.service

* vsftpd.service - Vsftpd ftp daemon

Loaded: loaded (/usr/lib/systemd/system/vsftpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2017-12-30 22:27:52 UTC; 2min 19s ago
  Process: 15641 ExecStart=/usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf (code=exited, status=1/FAILURE)
 Main PID: 15320 (code=killed, signal=TERM)

Dec 30 22:27:49 server systemd[1]: Starting Vsftpd ftp daemon...
Dec 30 22:27:52 server systemd[1]: vsftpd.service: control process exited, code=exited status=1
Dec 30 22:27:52 server systemd[1]: Failed to start Vsftpd ftp daemon.
Dec 30 22:27:52 server systemd[1]: Unit vsftpd.service entered failed state.
Dec 30 22:27:52 server systemd[1]: vsftpd.service failed.


Thinking I must have botched the vsftpd.conf file, I cloned this version of the original from github. However, it still throws the same error.

Before I messed with any settings, I was able to access with FileZilla on both an anonymous and a local user. Now I can not.

Here is the output of cat vsftpd.conf | grep -v "#" (these are the defaults given in the github link above):

anonymous_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
listen=YES

Any suggestions?

5
  • 1
    As suggested, what does journalctl -xe shows as relevant for vsftpd? Dec 30, 2017 at 22:55
  • journalctl freezes and shows no output
    – Naltroc
    Dec 30, 2017 at 23:10
  • I very much doubt that it freezes and shows absolutely nothing. Or you have far bigger problems than just vsftpd not running Dec 30, 2017 at 23:44
  • What if you start it manually outside of systemd, do you get any errors? Dec 31, 2017 at 10:02
  • Another stack exchange question/answer, albeit for a different error code, is serverfault.com/q/924456/101931
    – kbulgrien
    Aug 1, 2018 at 14:38

0

You must log in to answer this question.

Browse other questions tagged .