0

I have followed all the steps from this: http://docs.aws.amazon.com/ses/latest/DeveloperGuide/receiving-email-getting-started.html

I also believe I have done everything in here: http://docs.aws.amazon.com/ses/latest/DeveloperGuide/receiving-email-setting-up.html

My domain has been verified and I have setup the rule as specified in the first link but when I go to the S3 bucket I don't see anything there. I even tried making it public to see if this was permissions or something.

What am I missing here? I want to send an email to info@mydomain and see it in S3. If there is some other way of getting emails from a domain that I bough in Route 53 please let me know.

I have also setup an MX record on my domain with the following values:

10 inbound-smtp.eu-west-1.amazonaws.com

Every time I send an email to info@mydomain after a while I get an error about the email not being delivered.

What can I do to get this working???

EDIT: The only error I am seeing is from gmail saying:

Message not delivered
There was a problem delivering your message to info@example.com. See the technical details below.
LEARN MORE

The response was:
The recipient server did not accept our requests to connect. 

I don't want to put the domain because the website is still being built

EDIT 2: This is what I have for the domain in route 53. The value for the MX record is from aws ses documentation

enter image description here

  • I'm guessing there is some qualification needed for "If there is some other way of getting emails from a domain that I bough in Route 53 please let me know" as you can of course use any mail service you want. – Håkan Lindqvist Jan 1 '18 at 17:20
  • 3
    Generally speaking, it's a good idea to include the domain name in this type of question. – Håkan Lindqvist Jan 1 '18 at 17:20
  • @HåkanLindqvist There is no error that I can see from aws. The only error is when I try to send to the domain email, I get an error from gmail saying that it couldn't deliver the email – AntonioCS Jan 1 '18 at 18:03
  • "The recipient server did not accept our requests to connect" - are you accepting port 25 traffic? – Colt Jan 1 '18 at 18:24
  • 2
    Can you show dig output for the MX record to show that it's actually in correctly in place? The error message suggests that they are unable to connect to whatever is designated by the MX/address records for the domain. – Håkan Lindqvist Jan 1 '18 at 18:33
2

It appears you have you have an MX record at mail.example.com (if we use example.com as the zone name).

Is that really what you want? Are you actually intending to send mail to info@mail.example.com?

If not, make sure the MX record resides at the name that you are actually sending mail to (eg at example.com -> info@example.com).

| improve this answer | |
  • Wow... that was dumb of me. I really thought I needed something there. I have just changed the record to just be example.com and sent an email to info@example.com but unfortunately I still don't see anything in the S3 bucket. I will give it some more time. Thanks! – AntonioCS Jan 1 '18 at 23:03
  • It's quite possible that the non-existence response for MX is cached since your previous attempts (on the Gmail side, if that's what you are testing with). – Håkan Lindqvist Jan 1 '18 at 23:09
  • 1
    @AntonioCS do you see how much more quickly your question would have been solved if you hadn't redacted the domain name? I'm declining to vote to close this question (it's on the queue for closure) only so it can stand as yet another example of why redaction is unhelpful. – MadHatter Jan 3 '18 at 8:04
  • @MadHatter It wouldn't affect the question. What I should have done at the start is show all the data in route 53. – AntonioCS Jan 4 '18 at 8:48
  • 1
    @AntonioCS I see your point, but it doesn't hold: the questioner never reliably knows what's relevant, because they don't know what's wrong; that's why they're asking the question. Give all the information you can, and we can probably work out what we don't know, or failing that, ask for what we need. Make it easy for us, not yourself - you're the one asking for a favour. – MadHatter Jan 4 '18 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.