I have upgraded my Windows Server 2008 R2 to a new Windows Server 2012 R2 and installed AD DS, but when to trying to join other PCs to the domain it gives the following error:

The specified domain does not exist or could not be contacted.

Domain name is [Name.local]

After much troubleshooting, I figured out that I have to set static dns configuration in the client settings to point to the server IP. I already had set that in IPv4 from my experience with 2008 R2, but it worked only when I set the IPv6 too. Some clients needed to 'flush dns cache' or restart the machine before being able to join the domain.

My DHCP has a feature to distribute IPv6, but I am not familiar with this configuration.


My IPv4 configuration is as the following:
Gateway: 192.168.1.1
2012 R2 server: 192.168.1.2

DHCP:
Start IP address: 192.168.1.100
End IP address: 192.168.1.200
Lease Duration: 1 minute
Primary DNS server address: 192.168.1.1
Secondary DNS server address: 192.168.1.2
Static:
from 192.168.1.10 to 192.168.1.100 and,
from 192.168.1.200 to 192.168.1.254
same Primary & Secondary DNS Server

The available DHCP configuration for IPv6:

  • AutoConfigDNS
  • AutoConfigSubnet
  • Manual:
    (these are the available manual fields)
    Prefix:
    Prefix length: [16 - 64]
    Preferred lifetime: [60 - 4294967295 S]
    Valid lifetime: [60 - 4294967295 S]
    Primary DNS server address:
    Secondary DNS server address:

What DHCPv6 setting can work with the DHCPv4 setting to point the machines' DNS to the 2012 R2?

And what does the IPv6 of the 2012 R2 Server should be? and how configure it whether over GUI or CLI?

[update] The workaround of configuring IPv6 DNS has been working fine for a month, but now it stopped working, any idea how to troubleshoot this issue?

  • 1
    1. This isn't an IPv6 problem. 2. Why do you have such a ridiculously low DHCP lease time? That makes no sense and certainly isn't going to accomplish anything. 3. Your domain clients should use only the server for DNS. They should not use the Default Gateway for DNS. Same for the server itself. – joeqwerty Jan 1 at 16:29
  • 1. Why is it solved only with IPv6 DNS configuration? 2. That's because the 254 IPs seem not enough when 1 hour lease time, can you recommend other network subnet/configuration. 3. When using server only, clients have problems accessing the internet with the following error DNS_PROBE_BAD_CONFIG – Karim M.Z. Jan 2 at 13:52
  • Please post your additional questions as separate questions so people can help answer them. – user5870571 Jan 7 at 16:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.