2

We recently purchased a Dell R640 with Perc H740P Mini (Embedded) RAID controller. There are two 500GB SAS disks in RAID 1.

When we tried to install CentOS7.2 (via cdrom) from our custom image, we got the below error as it was not able to detect the hard disks.

enter image description here

And from this link (https://www.centos.org/forums/viewtopic.php?t=64039), we found that it could be an issue with CentOS 7.2 and it's fixed in CentOS 7.4.

So, I downloaded CentOS 7.4 and when I tried to install it, its giving me the below error. FWIW, the same iso image is working fine on a virtual machine.

enter image description here

I looked around but couldn't find anything amiss. I did try re-creating the virtual drive/running hardware diagnostics but nothing helped. PERC firmware is up to date.

Any pointers will be helpful.

Let me know if you have any queries, thanks.

  • is the virtual drive activated in the PERC firmware - does it show what size etc. – Sum1sAdmin Jan 2 '18 at 11:44
  • yes, virtual drive does show the size of the hard disk (558.38GB) – Ram Kumar Jan 2 '18 at 12:23
  • Then I would recommend that you use the lifecycle controller to deploy the OS which will load the correct drivers for the disk – Sum1sAdmin Jan 2 '18 at 12:27
  • I tried that too... That's also having the same issue mentioned above. – Ram Kumar Jan 2 '18 at 12:37
  • yikes! - so then - does the lifecycle controller show the disk as online and available? – Sum1sAdmin Jan 2 '18 at 12:40
1

You will have to download the newest driver from Dell and make it available during the CentOS 7 installation process. The following steps worked for me:

  • Ensure that the BIOS SATA Settings specify "AHCI Mode."
  • Configure your virtual disk in the H740P, not the S140.
  • Download the latest RHEL 7 driver (not the firmware) for PERC H740P from Dell's website. The download will include an iso.gz.
  • Unzip it to the ".iso" file.
  • Perform the OS installation from an iDRAC Virtual Console.
  • When booting to the installation, press 'e' on the "Install CentOS 7" line.
  • Append "inst.dd" to the linuxefi line and press F10.
  • Once the terminal rests at a prompt, mount the ".iso" file as a Virtual CD using iDRAC's Virtual Media feature. (You can unmount a virtual installation CD briefly if needed)
  • Enter 'r' at the prompt to refresh the listing.
  • Select the CD image. A driver should be detected.
  • Select to install the included driver (make sure the box is checked with an X), then continue.
  • Unmount the Virtual CD (and possibly remount what was previously there, such as an install iso).
  • The PERC H740P's virtual disk should be detectable now.
  • [Sorry for the delayed response] I did try similar steps but it didn't work as the build was still not able to see the disks. So, I installed CentOS7.4 and its working fine now. Thanks for your inputs. – Ram Kumar Feb 27 '18 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.