0

I've created Azure Load balancer and added two VMs to the backend pool but I'm not able to RDP to any of the VMs. I've made the required configuration as mentioned below

Inbound NAT Rules configured on the Load Balancer to allow RDP using custom ports i.e. 3000 (mapped to 3389) for VM1 and 3001 (mapped to 3389) for VM2.

NSG configured to allow inbound connections to port 3389.

NSG is configured at subnet level.

0

I've made the required configuration as mentioned below

According to your description, we should check our NSG settings.

1.Please check your NSG associate with VM interface, like this:

enter image description here

If there a NSG associate with it, make sure that NSG allow port 3389 in inbound rules.

2.Check Azure load balancer NAT rules settings:

enter image description here

Please check them, let me know if you need more help:)

  • Do we really need to attach NSG at the network level as it's already attached at the subnet level? – Amir Jan 3 '18 at 3:17
  • No,just to check it exist or not? No NSG for that VM works fine too – Jason Ye Jan 3 '18 at 3:19
  • To verify I ran Verify IP Flow via Network Watcher on port 3389 for both the VM's and it's accepting the traffic via the rule I've created RDP-allow in NSG. – Amir Jan 3 '18 at 3:24
  • What is the message when you try to connect it? – Jason Ye Jan 3 '18 at 3:42
  • I'm getting standard RDP message. Here is the screenshot imgur.com/a/uihTp – Amir Jan 3 '18 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.