I'm trying to view a https page on test12 server, from my MACHINE2, using a SSH Tunnel to connect to MACHINE1 which is on the same network as test12! But i can not display it.

test12 = https server - - same network as MACHINE1

MACHINE1 = windows 7 x64 - (the one running ssh server)

MACHINE2 = windows 7 x64 - (different network from MACHINE1)

MACHINE2 connects to MACHINE1 and creates a tunnel to on local port 443 and host


But when i navigate using iexplore from MACHINE2 to https://localhost i read "THIS PAGE CAN'T BE DISPLAYED"

So i edited C:\Windows\System32\driver\etc\hosts as follows: test12

and now by going on https://test12 i see different error message "THIS PAGE CAN'T BE DISPLAYED - Turn on TLS 1.0,TLS 1.1 and TLS 1.2."

So now dns name is test12 resolving to Could it be still mismatch because ip is not Should i change MACHINE2 ip address to

Can anyone tell me how to resolve it?

  • It's not mismatch it's TLS error. – Andrew Smith Jan 3 '18 at 15:07
  • For starters something on or CANNOT communicate with something on or without routing so test12 and MACHINE1 are not on the same network. You would be better off using routing instead of tunnels for this anyways. – Desultory Jan 3 '18 at 16:07
  • #Andrew Smith... Thanks for your answer, do you have any idea about how to fix it? – Neo_95 Jan 7 '18 at 10:19
  • #Desultory... Edited my question, test12 local IP Address is actually and COMPUTER1 can ping that address and connect via iexplore to https page on that ip address. also route -p, shows no routes to on COMPUTER1! Can you help me to solve? – Neo_95 Jan 7 '18 at 10:23
  • edited my question again! found out IP of test12 was actually – Neo_95 Jan 9 '18 at 16:08

Found the problem!

Using putty to create ssh connection between COMPUTER2 and COMPUTER1, in putty tool window under Connection-SSH-Tunnels create a tunnel with source port 2200 and dynamic destination - auto! resulting in D2200

Check Screenshot

After the connection is established, in iexplore settings, set socks proxy localhost:2200! Once done since socks proxy can't resolve dns you have to edit C:\Windows\System32\drivers\etc\hosts as follows: test12 and then navigating to https://test12 will show the page! Also suggest to install page certificate in trusted roots.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.