I've just finished building my new server and after I lost all my data from the raid1 due to a botched attempt to reattach the disks it hosed all my data. I've used the same disks and created a new array which has ext3 on it, but after restoring the backup, I've discovered the files copied to the new raid array are corrupted, it seems to be mainly my music collection especially the large files such as the .flac and .ape files.

I initally copied the files using samba off my ubuntu karmic desktop machine but when I ran into the above problems I tried NFS instead and the same thing happened.

It seems the file system is fine according to fsck.

The server is an Intel Atom 330 (Intel D945GCLF2 motherboard) with 2Gb ram and is running Ubuntu 9.04 amd64 edition. I'm out of ideas what could be causing the problem and would welcome some suggestions or even a way to check each files integrity as its copied across to see whats failing where.


First of all, are the files corrupt at the source? GIGO.

Don't forget that hard drives are not infallible. You can have silent errors on read that corrupt data.

If the files are OK on the source but get corrupted on the receiver, start testing individual components.

  • Network corruption? Use ttcp to check.
  • Memory corruption? Use memtest to check memory.
  • Disk corruption? Check SMART and generate some test data that gets checksummed before hitting the disk and afterwards.
| improve this answer | |
  • Interestingly I've copied files to other disks on the same system which are not in raid and those have checked out. The source files are also ok. Can I run smartctl on a raid array or do i need to do it each disk? – Stu Nov 28 '09 at 22:38
  • smart is on a per-disk basis. – Kamil Kisiel Nov 28 '09 at 23:42
  • Exactly, so check the SMART data on each disk. – MikeyB Nov 29 '09 at 2:02

A mass md5summing will do the job of integrity verification. I'm not going to speculate as to the cause of the corruption, there really isn't enough information here to make a reasonable diagnosis.

| improve this answer | |
  • What specific information do you require? and i'll see if I can provide it for you – Stu Nov 28 '09 at 21:55

This sounds kind of fishy to me, if I were in your position I would "sneaker net" (copy files to a flash drive and walk them to the desktop in question) and try to copy from the flash drive to the RAID array. If that works, then we know its a network based problem. I would suggest the steps that MikeyB said.

However, if the copy fails, then there is something bad funny going on.

You can try cp -v (verbose mode) and see if cp complains about anything. If not, then I would try cpio, probably won't make a difference but it is what I would try.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy