I have problem for install zendopcache

I try 1 time and other and always have the same result i don´t know what it´s bad because this can install with php 5.6 , thanks and also i delete and clean yum etc and the same response

>  [root@cp ~]# yum install php-pecl-zendopcache
>     Loaded plugins: fastestmirror, security
>     Setting up Install Process
>     Loading mirror speeds from cached hostfile
>     Excluding mirror: mirror.de.leaseweb.net
>     Excluding mirror: mirror.nl.leaseweb.net
>      * epel: mirror.23media.de
>     Resolving Dependencies
>     --> Running transaction check
>     ---> Package php-pecl-zendopcache.x86_64 0:7.0.5-2.el6 will be installed
>     --> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-zendopcache-7.0.5-2.el6.x86_64
>     --> Processing Dependency: php(api) = 20090626 for package: php-pecl-zendopcache-7.0.5-2.el6.x86_64
>     --> Finished Dependency Resolution
>     Error: Package: php-pecl-zendopcache-7.0.5-2.el6.x86_64 (epel)
>                Requires: php(zend-abi) = 20090626
>                Installed: php-common-5.6.33-1.el6.remi.x86_64 (@remi-php56)
>                    php(zend-abi) = 20131226-64
>                Available: php-common-5.3.3-49.el6.x86_64 (base)
>                    php(zend-abi) = 20090626
>     Error: Package: php-pecl-zendopcache-7.0.5-2.el6.x86_64 (epel)
>                Requires: php(api) = 20090626
>                Installed: php-common-5.6.33-1.el6.remi.x86_64 (@remi-php56)
>                    php(api) = 20131106-64
>                Available: php-common-5.3.3-49.el6.x86_64 (base)
>                    php(api) = 20090626
>      You could try using --skip-broken to work around the problem
>      You could try running: rpm -Va --nofiles --nodigest
>     [root@cp ~]#

I try many times and i try all and i don´t know what i can do for fix this, thanks for the help

Actually in server use Centos 6 64 bits, and run php 5.6


Zend OPcache is included with PHP 5.5 and later (and as from Remi) and is already installed on your system. You do not need to install the PECL package, which is only for PHP 5.5 or earlier.

If for some reason OPcache is not installed, try installing the php-opcache package from Remi.

  • but how configurate because i don´t see inside library as extension.so – Jos Jan 7 '18 at 4:12
  • On my system there is an /etc/php.d/10-opcache.ini which you can customize if you wish. See my edits. – Michael Hampton Jan 7 '18 at 7:23
  • it´s very strange i upgrade from 5.3 yo 5.6 without problems and in that folder no exists that file, the other .ini yes, i must create or howewer when upgrade must create this 10-opcache.ini, and no see in library the extension .so, yes other extensions, what do you think about this and what i must do in this case , thank´s – Jos Jan 7 '18 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.