1

We have a Windows Server on Azure, running flawless in the past year. After a Microsoft scheduled reboot/advisor recommendation, we lost access to this VM.

  • 'Connect' (RDP) button on Azure portal does not work.
  • Already tried resetting NIC, adding new NIC, redeploying to new host, everything without success.
  • Boot Diagnostics shows that VM started, but connection icon on lower right is at disconnected state: enter image description here

  • Pinging from another VM on the same vnet also failed.

Is there anything else that we can try to do to restore access to this VM?

  • It probably has a new IP address. Did you already account for that in your attempts to connect? – Todd Wilcox Jan 9 '18 at 15:36
  • @ToddWilcox, tried several new public IPs, setting local ip to static, reverting back to dynamic. No luck also. – rcmadruga Jan 9 '18 at 18:26
  • When you added the new NIC, did you make note of the IP address and then tried to RDP to that specific address? If not, try again. Allow that NIC thru the Azure firewall. Provided that your internal Windows firewall is not overly protective ... If that does not work, contact Microsoft support. The screenshot shows that the network is down in your VM. Is the Connect button grayed out or just does nothing? – John Hanley Jan 17 '18 at 0:32
  • Also, make sure that the IP address is actually a public IP address. If not then assign one to the NIC. – John Hanley Jan 17 '18 at 0:33
  • @JohnHanley, added new NIC and added public IP address. The Connect button is enabled. RDP to this public IP results in error as the server was offline. The network down on screenshot may be the issue... Even with two NICs it is offline on boot diagnostics. – rcmadruga Jan 19 '18 at 12:36
0

You may have already tried this, but stop the VM, so it shows up as de-allocated, then start it again. If that does not work then you need to raise a support ticket with MS to have them look at it.

  • Yes, already tried stopping and starting the VM. No luck. – rcmadruga Jan 9 '18 at 18:24
0

For the benefit of searchers, I had an issue where my RDP details (I'd saved the details locally) stopped working after a stop/start/reboot.

The problem was the IP address of the VM had changed!

Because I'd saved the details of my RDP, any new downloads of the RDP file didn't bring in the new IP address for some reason.

In the 'Overview' section of the VM on the Azure Portal, check the IP address. If you open the RDP file in notepad, you can see the IP it's trying to use. In my case, they were different (though that file had definitely worked before!).

Instead of using the downloaded RDP file, from my PC I did:

  1. Start > "Remote Desktop"
  2. Enter the new IP (from the overview section in Azure) followed by a colon, followed by the port e.g. 168.xx.xx.xxx:3389
  3. Hit Connect. (If you get asked for a username/password, you've found the server.)
  4. Go to More choices > Use a different account
  5. Enter .\myusername, then the password in the password box.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.