0

In our organization, there is a 10MB limit on email attachment size (through Exchange 2013). Most of our clients have another POP3/IMAP account too (in Outlook, besides their Exchange account). The problem is that when they want to attach files larger than 10MB to emails which are being sent from their POP3/IMAP account, Outlook 2016 prevents them with this message: "The file you're attaching is bigger than the server allows. Try putting the file in a shared location and sending a link instead.". How can we solve this "conflict"?

  • Are you sure the limit is enforced by Exchange and is exactly 10MB? Because by default, IMAP/POP3/etc. in Outlook is limited to 20MB (2010, 2013 and 2016, too). – Lenniey Jan 9 '18 at 13:36
  • @Lenniey yes, pretty sure. As you mentioned, default attachment limit is 20MB, but users can't attach e.g. 16MB files (which is above 10MB limit by Exchange). We tried increasing/removing Outlook's limit through registry fixes, no luck. The only remaining source for this limit is Exchange. – Mohammad H. Javaherizadeh Jan 9 '18 at 13:43
  • @Lenniey and one more thing: when we increase attachment limit in Exchange, the problem gets solved! This explicitly means that the problem comes from Exchange side. – Mohammad H. Javaherizadeh Jan 9 '18 at 13:50
  • Pretty sure this is expected behaviour. Outlook doesn't know which account you are going to send the email from and with Exchange as the default account that is what settings are applied to the new message. I don't think that behaviour can be changed. – Sembee Jan 10 '18 at 20:25
  • Where are they composing the message from, i.e. when they have a listing of emails open in Outlook are they looking at the listing on Exchange or from their IMAP account? If they click to the inbox of their IMAP account and compose a message do they get the error message? – JBaldridge Jan 18 '18 at 17:44
0

There is one step missing in the above solution.

Here is how you need to do it.

  1. Go to Microsoft Office 365 admin center.
  2. Go to Exchange admin center and select the recipient's mailbox.
  3. Select Mailbox features > Message Size restrictions.
  4. Increase the size to what you need.
  5. Go to regedit.exe
  6. Select HKEY_Current_Users > Software > Office > Outlook > Preferences
  7. Add a DWORD file named MaximumAttachementSize. Give it value 0 and hit Save.
  8. Close Outlook and restart the PC.
  9. Open Outlook. You will now be able to attach.
  10. If still not, add a new DWORD file in Outlook folder rather than adding it in Preferences folder and then restart PC.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.