0

I was integrating with woodpecker.co which required me to set up a sub-domain on mailgun before I could integrate my email.

I set up the DNS as requested and here is the result. Its from an VM running on Azure Portal

DNS settings

It appeared to work as you can see all the correct marks showed when I clicked the button to check DNS settings.

mailgun DNS check

I can send emails through the woodpecker service from my email now and also via outlook however when someone sends me an email I get the following error:

The response from the remote server was: 550 5.1.0 Recipient rejected:

Final-Recipient: rfc822; xxx@xxx.net Action: failed Status: 5.1.0 Remote-MTA: dns; mxb.mailgun.org. (34.232.219.201, the server for the domain xxx.net.) Diagnostic-Code: smtp; 550 5.1.0 Recipient rejected:

I did not touch any other mailgun or server settings. I have my own mail server and I have not touched any settings on this, the only thing I changed was the DNS settings. Should I just wait 24-48 hours, is it a propagating issue or did I break something with the new DNS settings? Maybe its because I created a new subdomain and I need to update something on my mail server. I don't really want to change anything on the mail server settings as a lot of things touch it and it could break them (well I guess its already broken but don't want to make it worse.)

Any ideas?

  • 1
    If you have your own mail server, why are you sending all your incoming mail to mailgun? – Michael Hampton Jan 9 '18 at 23:12
  • 1
    @MichaelHampton to be fair, only about 2/3 of the mail will be going to mailgun... – womble Jan 10 '18 at 1:24
  • Yep that was it, I removed the mx records for mxa and mxb and it worked. Might be obvious if I knew what mx records were for but I was just blindly changing records based on an article, feel free to add solution and I will select it as the answer. – user1547410 Jan 10 '18 at 21:55
  • What mx records did you instead that worked? You said you removed the two mx records so I'm assuming you replaced them with two other MX records? – Neil Anuskiewicz Jan 19 '18 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.