0

I'm trying to upgrade a Kubernetes multi-master cluster from v1.8.5 to v1.9.1 on Ubuntu 1604 LTS.

When I run sudo kubeadm upgrade apply v1.9.1 it gets as far as backing up the old manifest for kube-apiserver.yaml and then displays this:

[upgrade/staticpods] Waiting for the kubelet to restart the component

It then waits for 60 seconds (apparently a hard-coded time-out in kubeadm) before restoring the original state.

There's nothing obvious in the logs. What could be the issue?

0

It turned out to be a problem with the single nodeName in the kubeadm-config being hard-coded to the name of one of the other masters.

I edited it with this command:

kubectl edit cm -n kube-system kubeadm-config -o yaml

and changed the nodeName in the MasterConfiguration section to match the name of the master being upgraded, and then it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.