0

macOS

Google Cloud SDK 183.0.0
beta 2017.09.15
bq 2.0.27
core 2017.12.08
gcloud
gsutil 4.28
kubectl

I have tried revoking the login and logging in again but every command of gcloud docker refreshes the access token so it hangs about 30 seconds before actually executing a command.

$ gcloud --verbosity=debug docker -- --help                                                                                                                                                      
DEBUG: Running [gcloud.docker] with arguments: [--verbosity: "debug"]
INFO: Refreshing access_token

$ gcloud --verbosity=debug docker -- --help                                                                                                                                                          
DEBUG: Running [gcloud.docker] with arguments: [--verbosity: "debug"]
INFO: Refreshing access_token

Any ideas what could be causing this?

Login Debug Log

$ gcloud --verbosity=debug auth login                                                                        
DEBUG: Running [gcloud.auth.login] with arguments: [--verbosity: "debug"]
Your browser has been opened to visit:

    https://accounts.google.com/o/oauth2/auth?redirect_uri=http%3A%2F%2Flocalhost%3A8085%2F&prompt=select_account&response_type=code&client_id=32555940559.apps.googleusercontent.com&scope=https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcloud-platform+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fappengine.admin+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcompute+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Faccounts.reauth&access_type=offline


INFO: Successfully retrieved access token
WARNING: `gcloud auth login` no longer writes application default credentials.
If you need to use ADC, see:
  gcloud auth application-default --help

You are now logged in as [xxx].
Your current project is [xxx].  You can change this setting by running:
  $ gcloud config set project PROJECT_ID
INFO: Display format "none".
  • I tried to reproduce this in Linux OS but getting instant response from the same command. Moreover, I tried with other gcloud docker command - gcloud docker --authorize-only and getting an immediate response. Can you please try to execute these command from VM instance and not from the cloud shell? – D Saini Jan 13 '18 at 2:05
  • @DSaini Hello thank you for commenting. On the VM itself, gcloud docker --authorize-only gets an immediate response as well. It's just on my macOS machine that I'm getting this. Just tried reinstalling gcloud and clearing my config but still get the same delay. Any other suggestions? – Axsuul Jan 14 '18 at 0:49
  • Thanks for sharing the feedback. This isolate the issue with respect to Mac OS. Going forward, I would suggest to report this issue as a Customer Issue/Bug on Google public issue tracker(PIT) platform. – D Saini Jan 15 '18 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.