1

I am running ESXI 5.5 and I am trying to remove the snapshots from our office server VM (SBS 2011). Yesterday afternoon I started the process and this morning it seems to be only at 5%, which means it will take another 2 weeks to finish! I have 17 snapshots, probably going back a year or 2. I have since read I should only have max 2-3 over 72 hours. Can I cancel the removal process and is there an alternative to removing snapshots? perhaps I make a new VM based on the over snapshotted VM?

Update: Under the Datastore Browser, only one of the files (C:drive vmdk) had been 'modified' at just 10 mins after I initiated the 'Delete All' snapshots yesterday. I cant wait 2 weeks and I have a backups if something is corrupt, so I cancelled the removal task, and a few moments later the task was marked complete and all snapshots are gone from the snapshot manager, but still there in the Datastore Browser. The VM is back online now. So I'm still looking for alternative way to tidy up this VM. Can I somehow create a new VM that would consolidate all snapshots?

  • 2
    FYI VMFS Snapshots shouldn't be thought of as backup or anything even moderately long-term. We have a 72 hour rule for snaps, they shouldn't be around that long for exactly the reasons you're seeing. Have a think about a similar rule where you are. – Chopper3 Jan 13 '18 at 14:56
2

You can think of snapshots as actually creating a new virtual disk that new writes are committed to. And then when a new read or write happens, data from all inline snapshots are used. This isn’t exactly what happens, but it’s close enough to illustrate the point.

What’s happening when you delete the snapshots is it’s merging years of writes from 17 snapshot volumes into the single main virtual disk.

This will take a long time. There is no alternative.

  • Thanks for your reply, I thought that might be the case.I cant wait 2 weeks, so I either need to cancel the process and put it back online, or if this is not possible, then perhaps I need to make a new VM from the backup. – ARNiTECT Jan 13 '18 at 12:15
1

Normally the only way to get rid of snapshots is to delete them, but given your situation, I think the better approach, oddly enough, is to take another snapshot right now.

Ideally you'd shut down the VM in question, then take the snapshot so that it's in a nice clean state, but that might not be possible for you.

In any event, once you have this most recent snapshot, you can actually create a new VM based on it, using PowerCLI. The command would be something along the lines of:
New-VM -Name $CloneName -VM $SourceVM -Location $CloneFolder -Datastore $Datastore -ResourcePool $ResourcePool -VMHost $VMHost -LinkedClone -ReferenceSnapshot $Snapshot
You can look here for what all the options mean and how to use them.
They key is the -ReferenceSnapshot option.

Once the clone is done, you power off the heavily snapshotted VM, and power on the new VM, and voila, a you're back in business without having to delete all the snapshots.

All you'd have to do after that is establish some better polices around snapshot management!

  • Thanks, I like the sound of that plan. I've just been reading about Cloning a VM. I understand it would be much faster but would perhaps still take several hours as the VM contains 6 disks totalling about 3TB. I also need to free up a lot of space first assuming I'll need the same amount for the clone. – ARNiTECT Jan 13 '18 at 13:00
  • 1
    Yeah, you'll need the free space to do it, and it won't happen instantly, but I'll probably be faster than consolidating the snapshots. – GregL Jan 13 '18 at 13:02
  • Unfortunately, I've had some difficulty cloning the VM. I installing VMware PowerCLI, but I am not familiar with it. I tested cloning a 160Gb VM on vSphere Web Client eval & it cloned fine with all snapshots removed. I then tried the larger VM but 'Operation timed out' at 33%. I tried, restart host, more memory to vcenter appliance. It creates 1 vmdk file thin 250gb / actual 0.5gb. My datastore has 2.5TB free & the VM to clone is approx 1.5TB actual & 3TB thin provisioned. The server is a napp-it/omnios 'all-in-one'. After the cancelled 'delete all', at least the VM still appears to work. – ARNiTECT Jan 14 '18 at 20:39
  • I upped the vcenter appliance to 10gb memory and after 12hours the cloning got to 63% and 1tb! ....and then timed out. – ARNiTECT Jan 15 '18 at 9:15
  • Are you cloning the snapshot with PowerCLI? Cause as far as I know you can't download what I'm suggesting with any of the clients. – GregL Jan 15 '18 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.